2nd 2960 switch

At one of my work sites I want to add an additional managed switch.  There is currently a Cisco 2960G and I want to add a 2nd one because we ran out of ports.  Basically I just want to add ports for a particular Vlan.  
Is there a way to configure these as a stack?  What is the easiest/best way to configure the 2nd switch?
tike55Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Brian BEE Topic Advisor, Independant Technology ProfessionalCommented:
The best thing to do is buy a stacking cable kit. That will allow you to use the switches together as a single switch.

The other option is to just connect them together with a network cable, but that will cause a bottleneck for any data that has to travel between the two switches.
0
tike55Author Commented:
2960's are not stackable.
0
tike55Author Commented:
From some quick research I will need to connect them with a simple trunk interface.  What is the easiest/best way to configure the trunk interface?
0
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

Brian BEE Topic Advisor, Independant Technology ProfessionalCommented:
Sorry. Yes, 2960G is not stackable, other 2960 models are, with the addition of a stacking kit.

You'll have to trunk it the other way as I said. I found a good posting that details what to do here:

https://supportforums.cisco.com/t5/lan-switching-and-routing/2960g-stack-to-another-2960g/td-p/1790000
0
tike55Author Commented:
I want to keep the current port configuration of the first switch.  Can I just configure 1 port on the server switch for VTP?  Or will I have to completely reconfigure the switch?
1
DP230Network AdministratorCommented:
Yes, you have to configure both switches as below:

Switch 1 ----------------------------------- int g0/1 (in both ends) ---------------------------------------Switch2


Switch1#(config) int g0/1
Switch1#(config-if) switchport mode trunk
Switch1#(config-if) switchport trunk encapsulation dot1q


Switch2#(config) int g0/1
Switch2#(config-if) switchport mode trunk
Switch2#(config-if) switchport trunk encapsulation dot1q

Switch1#(config) vtp domain name test.com
Switch1#(config) vtp mode server
Switch1#(config) vtp version 2
Switch1#(config) vtp password secret

Switch2#(config) vtp domain name test.com
Switch2#(config) vtp mode client
Switch2#(config) vtp version 2
Switch2#(config) vtp password secret

if you already had vlan configuration on switch1, that information will be replicated to switch2; then you just need to plug devices into switch2 and assign vlan on those ports of switch for those devices
example:
conf t
int range f0/10 - 20
switchport mode access
switchport access vlan 10
1

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
atlas_shudderedSr. Network EngineerCommented:
What is the exact model of the switch you currently have and what is the model you want to purchase.  That will go a long way in helping to give you a path ahead.  Everything noted above is accurate but not necessarily applicable depending on the model(s) involved.  If you can stack, then you just confirm that the existing switch will remain master in the stack, all other configuration information, except for the individual port configurations for the new switch, would be adopted down by the supplicants.  If you are not able to stack, yes you could use VTP but it is not advisable, better to copy over your base config and clear all the interfaces, etc. then trunk it up.

Once you provide the model numbers then we can move forward on an actual solution instead of the spitballs.
0
tike55Author Commented:
Both Switches are 2960G's

I would not like to use VTP.   No Stack Kit available for these switches.   I know how to copy over the base config, but after could you give me an example of  how to trunk it?
0
atlas_shudderedSr. Network EngineerCommented:
Tjno has a good example above for building your trunk
1
tike55Author Commented:
So Just so I get it right:


Switch #1:  

Switch1#(config) int g0/1
 Switch1#(config-if) switchport mode trunk
 Switch1#(config-if) switchport trunk encapsulation dot1q


Switch #2:
 
 Switch2#(config) int g0/1
 Switch2#(config-if) switchport mode trunk
 Switch2#(config-if) switchport trunk encapsulation dot1q
0
atlas_shudderedSr. Network EngineerCommented:
Yes, assuming you are going to use gig0/1 on each switch for the trunk.  If not, change as appropriate.
0
tike55Author Commented:
Thanks,

2 more sub-questions:

1) If I add a 2nd network cable/ trunk will it make the performance faster?
2) It would be ideal to add the trunk on one of the fixed ports 45,46,47,48, correct?
0
DP230Network AdministratorCommented:
In my opinion:
1. Yes, faster and redundancy
You can also assign which VLAN can transmit through which interface by command:
int g0/1
switchport trunk vlan 10, 20, 30

Open in new window


2. That is your switch, you can add trunk to any port you like :-) but I usually add trunk in gigabit port
If you were asking about the SFP slots, usually they will be used as trunk when the range is very far (fiber cable will be used in this case)
0
Benjamin Van DitmarsSr Network EngineerCommented:
to use mulitple ports you need to configure a port-channel

Switch1#(config) int port-channel 1
Switch1#(config-if) switchport mode trunk
Switch1#(config-if) switchport trunk encapsulation dot1q
Switch1#(config-if)!
Switch1#(config)int range gig 0/45-48
Switch1#(config-if) channel-group 1 mode active
Switch1#(config-if)!

Switch2#(config) int port-channel 1
Switch2#(config-if) switchport mode trunk
Switch2#(config-if) switchport trunk encapsulation dot1q
Switch2#(config-if)!
Switch2#(config)int range gig 0/45-48
Switch2#(config-if) channel-group 1 mode active
Switch2#(config-if)!
0
tike55Author Commented:
How would I assign the vlans to the port channel?
0
DP230Network AdministratorCommented:
"How would I assign the vlans to the port channel?"

==> config mode
int port-channel 10
sw trunk encapsulation dot1q
sw trunk native vlan 99
sw mode trunk

More details can be found on Internet or books: https://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst3750x_3560x/software/release/12-2_55_se/configuration/guide/3750xscg/swethchl.pdf
0
atlas_shudderedSr. Network EngineerCommented:
Actually, as long as you aren't restricting vlans on any of the port channels/trunks, then any vlan that is active on the switch will automatically populated to the port channel/trunks on that switch. So, as VTP propagates the vlans among the switches, the vlans will start showing on the trunks and in spanning tree.

The information immediately above is for setting the native vlan on the trunks and has no impact on what vlans are actually passed on the trunks. In the event that you decide to change the native vlan as noted above, be sure you have access to all switches and start with the switch that is farthest from you in the network. Once you change the native vlan on the trunk you will lose the trunk until both sides match.
0
tike55Author Commented:
I don't want to use VTP.

2 sub questions and I am good:

1) If I use a port channel, and do not define VLans, the native vlan trunk will automatically be populated, correct?
2) Can I just set up 2 trunks, without a port channel?  If so, the same applies correct? (I don't have to define the vlans on the trunks)
0
atlas_shudderedSr. Network EngineerCommented:
Correct, on both points tike
0
tike55Author Commented:
and 1 final final sub question ;)  :

is it preferable to do a port channel, or setup 2 trunks?  or are both options viable.
0
atlas_shudderedSr. Network EngineerCommented:
a port channel is a trunk(generally), comprised of 2 or more physical ports.  If you are uplinking between switches I would go with a port-channel rather than a single trunk interface.  Offers some degree of resilience.
0
tike55Author Commented:
When I try to create the port channel using Benjamin Van Ditmar's suggestion above,  

I get Invalid input detected at

#switchport trunk  encapsulation dot1q
                                  ^
% Invalid input detected at '^' marker.
0
atlas_shudderedSr. Network EngineerCommented:
On newer equipment/IOS versions the encap dot1q command is not supported any longer.  This is because cisco has ceased pushing ISL as an alternative trunking protocol.

Try this:

If building single interface trunks between two switches:

Switch 1:
int gig x/x
sw trunk encap dot1 (if it fails, don't worry about it and move on)
sw mode trunk
no shut

Open in new window


Switch 2:
int gig x/x
sw trunk encap dot1 (if it fails, don't worry about it and move on)
sw mode trunk
no shut

Open in new window


If you are building multiport trunks (port-channels) then do use the following instead:

Switch 1
int ra gig x/x - gig x/x
channel-group 1 mode active
no shut
int po 1
sw trunk encap dot1 (same as above, if it fails, move on)
sw mode trunk
no shut

Open in new window


Switch 2
int ra gig x/x - gig x/x
channel-group 1 mode active
no shut
int po 1
sw trunk encap dot1 (same as above, if it fails, move on)
sw mode trunk
no shut

Open in new window


Make your physical connections and test
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Cisco

From novice to tech pro — start learning today.