New task created not functioning and not displayed under tasks scheduler.

bfuchs
bfuchs used Ask the Experts™
on
Hi Experts,
I created today a new task from task scheduler wizard and its not working.
Dont even see that listed under all other tasks!!
However under C:\Windows\System32\Tasks I see it.
How can I troubleshoot this?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
AndyAinscowFreelance programmer / Consultant

Commented:
>>However under C:\Windows\System32\Tasks I see it.

What does that mean?  That is a folder, not an app running.
Top Expert 2016

Commented:
open the task file using notepad and check the xml is proper, perhaps copy it and post the xml here .. put in dummy values for any confidential data
@Andy,
I read on google that tasks get stored there, went to look and saw it there.

@David,
Here it is..
<?xml version="1.0" encoding="UTF-16"?>
<Task version="1.2" xmlns="http://schemas.microsoft.com/windows/2004/02/mit/task">
  <RegistrationInfo>
    <Date>2018-06-20T18:11:01.7971474</Date>
    <Author>WG\b.fuchs</Author>
  </RegistrationInfo>
  <Triggers />
  <Principals>
    <Principal id="Author">
      <RunLevel>LeastPrivilege</RunLevel>
      <UserId>WG\b.fuchs</UserId>
      <LogonType>Password</LogonType>
    </Principal>
  </Principals>
  <Settings>
    <MultipleInstancesPolicy>IgnoreNew</MultipleInstancesPolicy>
    <DisallowStartIfOnBatteries>true</DisallowStartIfOnBatteries>
    <StopIfGoingOnBatteries>true</StopIfGoingOnBatteries>
    <AllowHardTerminate>true</AllowHardTerminate>
    <StartWhenAvailable>true</StartWhenAvailable>
    <RunOnlyIfNetworkAvailable>false</RunOnlyIfNetworkAvailable>
    <IdleSettings>
      <StopOnIdleEnd>true</StopOnIdleEnd>
      <RestartOnIdle>false</RestartOnIdle>
    </IdleSettings>
    <AllowStartOnDemand>true</AllowStartOnDemand>
    <Enabled>true</Enabled>
    <Hidden>false</Hidden>
    <RunOnlyIfIdle>false</RunOnlyIfIdle>
    <WakeToRun>false</WakeToRun>
    <ExecutionTimeLimit>P3D</ExecutionTimeLimit>
    <Priority>7</Priority>
  </Settings>
  <Actions Context="Author">
    <Exec>
      <Command>C:\Application\CopyCaspioTablesToServer.bat</Command>
    </Exec>
  </Actions>
</Task>

Open in new window


Thanks,
Ben
Rowby Goren Makes an Impact on Screen and Online

Learn about longtime user Rowby Goren and his great contributions to the site. We explore his method for posing questions that are likely to yield a solution, and take a look at how his career transformed from a Hollywood writer to a website entrepreneur.

Just to clarify, I'm searching for it at the attached.
Perhaps I'm looking at the wrong place..?

Thanks,
Ben
Untitled.png
Top Expert 2016

Commented:
You didn't give it a name, under author you should have  <URI>\Scheduled Task Name</URI> </RegistrationInfo>2018-06-21_13-26-39.jpg
You didn't give it a name,
So are you saying, I should manually add that to the file?
why isn't it there to begin with?
and where do I put the "</RegistrationInfo>"?

Thanks,
Ben
Top Expert 2016

Commented:
I have no idea, use the same name that the task is in ..\tasks
Did that, now see attached..

Thanks,
Ben
Untitled.png
Top Expert 2016
Commented:
Delete and recreate the task is all that I can think of right off now.. probably fastest fix
Shaun VermaakSenior Consultant
Awarded 2017
Distinguished Expert 2018

Commented:
You cannot edit the XML files, they are "signed" after creation. Recreate it. How did you initially create it?
How did you initially create it?
Using the task scheduler wizard, shown on attached above, clicked on create new task..

Thanks,
Ben
Hi Experts,

I realized the problem only happens when I use create task option, however when using create basic task.. option then I dont have this issue.
Any idea why?

Thanks,
Ben
Thanks experts!

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial