Problem with detection of an IP address

I have a Windows 10 PC (Version 10.0.17134 Build 17134) where a VMware is installed (Version 12.5.9 build-7535481) with Windows 10 (Enterprise N 2015 LTSB). We have a problem with the IP address of this "VMware PC". The "hosts" file in C:\Windows\System32\drivers\etc, there is the entry for the VMware PC as WIN10PC (see attachements). There is a second "hosts" file in C:\WinSxS\amd64_microsoft-windows… without any entries, but trying to add the WIN10PC entry also there fails because of the message:

Cannot save "amd64" hosts fileHowever, I have opened this hosts file only in the Notepad++ app. A ping on WIN10PC cannot find the address of 172.10.10.153 and returns the own IP address of the Windows 10 PC, which is 172.10.10.150. The arp command does not enlist the WIN10PC address of 172.10.153 at all, and an "arp -s" command will not add this IP address (see attachements). Interestingly, my colleagues can "see" the VMware machine from their PCs!

Do you have any idea what's going wrong?
hosts.txt
20180627-VMware-Windows-10.txt
20180627-Windows-10-PC-2.txt
LVL 1
Ahmet Ekrem SABANSenior IT consultantAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Are you using Bridged Networking in the VM Network Settings ?
0
Michael PfisterCommented:
Ignore the hosts file under C:\Windows\WinSxS\amd64_microsoft-windows…
If a host name is in this file something went completely wrong. This is the source for the Windows setup, it contains only values that are commented out (#).

From you're decription its not clear what you're trying.
So if you're trying to resolve the IP of computer A on computer B, add computer A's IP address and name in the C:\Windows\System32\drivers\etc\hosts on computer B.
0
George WaltonRemote Administrator LMCommented:
Try to use cmd.exe
flushdns
1
Powerful Yet Easy-to-Use Network Monitoring

Identify excessive bandwidth utilization or unexpected application traffic with SolarWinds Bandwidth Analyzer Pack.

Ahmet Ekrem SABANSenior IT consultantAuthor Commented:
Thank you for your replies! I already tried flushdns but no avail. Michael Pfister, you grasped it: I added computer A's address (the VMware machine with Windows 10) to the hosts file of the computer B (the Windows 10 PC). And Andrew Hancock, the Virtual Machine Settings "Hardware" / "Network Adapter" has in the "Device status" "Connected" and "Connect at power on" checked, and in "Network connection" the Bridged radio button checked.

What I also did after talking to another colleague here, who had the same problem, is to update all drivers on the Windows 10 PC. But it didn't solve his problems, so he continued to with a complete reinstallation of his PC. That's what I think to do as a last resort.
0
Michael PfisterCommented:
Could be also the firewall on the Win 10 target blocking ping. Usually a system not in domain enables the "Public" firewall profile on the network interface and blocks most incoming traffic.
0
Ahmet Ekrem SABANSenior IT consultantAuthor Commented:
We deactivated the firewalls on the real & virtual PC when the problem seem to be tough. Interesting is that arp -a does not show the address, and adding 172.10.10.153 (alias WIN10PC) with arp -s doesn't solve the problem. However, my colleagues in the room can see WIN10PC from their PCs.
0
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Reset the Network settings of VMware Workstation to Network Defaults.

Is your VM set to DHCP or Static ?

if set to DHCP does it obtain an IP Address from the DHCP server on the LAN ?

by doing the latter confirms networking is working in the VMware Workstation
1
Ahmet Ekrem SABANSenior IT consultantAuthor Commented:
Here are my network settings:
VMware Network Adapter settings with "Advanced…"
NAT isn't selected. I hope they are the default. Where can I see the settings concerning DHCP/static?
0
Michael PfisterCommented:
From your txt files with ipconfig output I see the host has a static IP, the guest VM has DHCP enabled and is getting an IP address from 172.10.10.27. So basic network connection is there
All this won't explain why you can't ping from host to guest,

Lets start over:
reboot host & guest

On host open a command prompt and run:
ipconfig /all > eehost.txt
ping 172.10.10.153  >> eehost.txt
ping 172.10.10.27  >> eehost.txt
ping WIN10PC >> eehost.txt
tracert 172.10.10.153>> eehost.txt

Open in new window



On guest open a command prompt and run:
ipconfig /all > eeguest.txt
ping 172.10.10.150  >> eeguest.txt
ping 172.10.10.27  >> eeguest.txt
ping WIN10PC >> eeguest.txt

Open in new window

0
Ahmet Ekrem SABANSenior IT consultantAuthor Commented:
The host is the Windows 10 PC, the guest the VMware Windows 10 PC. Here are the files…
eehost.txt
eeguest.txt
0
Michael PfisterCommented:
So the communication works via the bridged network, you can ping 172.10.10.27.
As long this isn't some strange VMWare behaviour it still looks like a firewall issue.
Please double check the Windows firewall is really deactivated in your active network profile on both systems (host and guest)

Also test if you can connect i.e. to C$ from guest to host by i.e. mapping a network drive to \\172.10.10.150\c$. You problably have to provide admin credentials for the host
0
Michael PfisterCommented:
Sorry must have been blind. Please remove Checkpoint software from your host, reboot and retry:

Ethernet-Adapter LAN-Verbindung* 3:

   Medienstatus. . . . . . . . . . . : Medium getrennt
   Verbindungsspezifisches DNS-Suffix: 
   Beschreibung. . . . . . . . . . . : Check Point Virtual Network Adapter For Endpoint VPN Client #2
   Physische Adresse . . . . . . . . : 54-A6-80-66-02-03
   DHCP aktiviert. . . . . . . . . . : Ja
   Autokonfiguration aktiviert . . . : Ja

Open in new window

0
Ahmet Ekrem SABANSenior IT consultantAuthor Commented:
I am not allowed to remove Checkpoint Endpoint Security VPN from the company PC that hosts the VMware.
0
Ahmet Ekrem SABANSenior IT consultantAuthor Commented:
I think I will do what my colleague did here after trying to solve this problem for three days: to re-install the image I created two weeks ago of the host PC…
0
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Did you RESET VMware Workstation networking to Defaults, using the Virtual Network Editor ?

2018-06-28-13_12_00-Virtual-Network-.png
Hit Restore Defaults
0
Ahmet Ekrem SABANSenior IT consultantAuthor Commented:
I downloaded the Virtual Network Editor for VMware 12, as I have VMware 12.5.9, and copied it to the directory C:\Program Files\VMware\VMware Player. When starting the EXE, I got the error that sigc-2.0.dll is missing several times. So, I downloaded this DLL and put it into the same directory of the VM. As I got an error message, I copied the DLL to C:\Windows\System32. The error message is still the same:

vmnetcfg.exe - Application error
(vmnetcfg.exe - Application error

The application could not be started correctly (0xc000007b).
Click "OK" to close the application.)


After a restart of the VMware, system error occurs because of the missing vmwarebase.dll.
0
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Virtual Network Editor is installed with VMware Workstatiion, not sure where you downloaded it from, but it's clearly the wrong version.!!!

Ah, you have VMware Player, and not VMware Workstation Pro ?

VMware Player does not ship with network editor.
0
mphillip85Commented:
if you are trying to ping a windows 10 pc then by default the ICMP (Echo reply) is by default blocked by the firewall on the PC you are trying ot communicate.  Temporarily disable the firewall or add an entry to allow ICMP to be allowed to the networks you deem necessary or choose ALL.
You can look for the exact settings by searching for "enable ICMP on firewall with Windows 10"
0
David Johnson, CD, MVPOwnerCommented:
he can't disable the firewall (checkpoint) .. is there a reason you did not use hyper-v?
0
Ahmet Ekrem SABANSenior IT consultantAuthor Commented:
We activated Hyper-V, but that resulted in an error that led us to a Web page where it was advised to deactivate it! :-D
0
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
You cannot use VMware Workstation and Hyper-V, together, you've got to disable one of them.....

so you create two different BOOT menus, and select which one Hyper-V or VMware Workstation you use at boot.

it's either or...

https://www.eightforums.com/threads/hyper-v-and-vmware-on-the-same-machine.48077/
0
Ahmet Ekrem SABANSenior IT consultantAuthor Commented:
Thank you all for your help. As we spend nearly two days because of this issue on my colleague, we decided to set back to a former image. The colleague that tried for three days also wanted to see how Hyper-V can be used in this context. Actually, we didn't know about that tool.
0
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
I think I would uninstall VMware Workstation Pro, and re-install, and also check why you are missing the virtual network editor, which should be present with Workstation Pro (but not Player)

or consider using Hyper-V which is far better,a dn performs better, because it's a Type 1 hyper visor and part of the OS, and not an application like VMware Workstation Pro!
0
Ahmet Ekrem SABANSenior IT consultantAuthor Commented:
What we did was to revert to the last working image on that PC. Unfortunately, we found out that that image does also have the same problem. So, I am using another PC, and the buggy PC is reinstalled without using an image. :-> We didn't switched to Hyper-V, as everybody in the company involved in development or QS does already use VMware.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 10

From novice to tech pro — start learning today.