Not able to publish application on RDS server 2012

Nick Perks
Nick Perks used Ask the Experts™
on
Hey Guys,

I am trying to public Quickbooks 2018 APP on RDS hosted on 2012 R2 Standard server.
Currently there is Outlook 2013 and Remote desktop connection which are successfully published.
There was Quickbooks 2017 that was published earlier but I removed it as I installed the latest version of quickbooks 2018
which I now want to publish.

Under my current collections, under RemoteAPP program I tried publishing it but it gives me an error saying the app cannot be published.

Status: Failed: Could not create a published application instanced on the server  server.domain.local.

It still for some reason adds to the list of Remote APP Program box. Screen shot:

Capture.JPG

Just to test I tried publishing calculator but same error. I could not find any errors entries in event log on this server.

When user logs on to the web portal for RDS, they only see Outlook 2013 and RDP shortcuts. I did tried rebooting server
but still the same.

What am I missing ? Are there additional steps those I need to take ?  This is the first time I am attempting publishing the app.

Thanks
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
check your web server certificate in collections and see if it is expired.  found a couple of posts with the same issue and the cause was an expired certificate.

Our issue was expired certificates in the RD server set-up which were interfering with the system even though in IIS they were all up-to-date and the server was working fine.

So under server manager we went into the RD settings and then highlighted the deployment and under tasks chose 'edit deployment properties' and went to the certificates page:


https://blog.sircles.net/post/2017/04/19/publishing-failed-for-rdsh-collection-remoteapp-name-collection-name-failure-could-not-create-a-published-application-instance-on-the-server
https://social.technet.microsoft.com/Forums/ie/en-US/288f1758-769e-4839-8504-da2a1dd5d34d/problem-with-publishing-remote-apps-in-server-2012?forum=winserverTS
Nick PerksIT Director

Author

Commented:
Thank you. It was ditto the first link that described the issue that fixed the issue. Certificate was already valid under IIS. I exported it in documents.

I then went to deployment properties and selected each of the RDS service and replaced the current invalid cert with this exported on. Unpublished and published the app and it worked like a charm.

Thanks again!
Hey man glad I could help.  I remember when I deployed 2008 rds for the first time and a year later one of the certs expired.  Took me a while to figure it out.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial