Sometimes lose ability to properly use mouse within Hyper-V virtual machines

Sometimes while I am working within Server 2016 Hyper-V virtual machines (on a Server 2016 Hyper-V virtual server) I lose the ability to use the mouse within the virtual machine. This happens no matter what size the virtual machine window is (including if it is maximized). However, I am still able to use the keyboard to navigate around the virtual machine.

These virtual machines are fully integrated with the host operating system and all updates have been installed on the base server and virtual machines. When this issue occurs it occurs on only one of the virtual machines (the other virtual machines continue to run properly without having this problem).

I will be able to move the mouse pointer but when I click, double click, or right click on items within the virtual machine these clicks aren't recorded by the virtual machine.

In an attempt to fix the problem, I have tried restarting the Windows Explorer program within the virtual machine but this never fixes the issue.

I will then need to login to the virtual machine using Remote Desktop or restart the virtual machine to fix the problem.

When this issue occurs, what else can I do to fix this issue?
IT GuyNetwork EngineerAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Philip ElderTechnical Architect - HA/Compute/StorageCommented:
Enhanced or Standard session? Try flipping between the two using the console's menu.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
IT GuyNetwork EngineerAuthor Commented:
This issue happened again this weekend and I tried switching between both Enhanced and Standard and this didn't fix the issue.

What else can be done to fix this issue besides rebooting the virtual machine or establishing a remote desktop session to the virtual machine?
0
Philip ElderTechnical Architect - HA/Compute/StorageCommented:
Are the host and guests running at the same patch level?
0
IT GuyNetwork EngineerAuthor Commented:
Yes, they both have all Server 2016 updates installed.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Virtualization

From novice to tech pro — start learning today.