Trouble updating BIOS on Intel DH67BL Motherboard

Hi

I have an Intel DH67BL motherboard version AAG10189-209. The current BIOS version is v119 which is too low to support an i7-3770 CPU. Intel have confirmed in a support chat and I have located documentation that states that the board (version) is compatible with this CPU.

SPECCY reports
=============
Manufacturer            Intel Corporation
Model                        DH67BL (LGA1155)
Version                        AAG10189-209
Chipset Vendor            Intel
Chipset Model            Sandy Bridge
Chipset Revision            09
Southbridge Vendor      Intel
Southbridge Model      H67
Southbridge Revision      B3
System Temperature      35 °C
BIOS
      Brand      Intel Corp.
      Version      BLH6710H.86A.0119.2011.0523.1030
      Date      23/05/2011

WINDOWS 10 reports
==================
OS Name                              Microsoft Windows 10 Pro
Version                                    10.0.17134 Build 17134
OS Manufacturer                        Microsoft Corporation
System Type                              x64-based PC
Processor                              Intel(R) Pentium(R) CPU G620 @ 2.60GHz, 2600 Mhz, 2 Core(s), 2 Logical Processor(s)
BIOS Version/Date                  Intel Corp. BLH6710H.86A.0119.2011.0523.1030, 23/05/2011
SMBIOS Version                        2.7
Embedded Controller Version      255.255
BIOS Mode                              Legacy
BaseBoard Manufacturer            Intel Corporation
Secure Boot State                        Unsupported

I am aware that I have to apply the "transition" update due to the significant BIOS restructuring that is required for the gen 3 processors. All attempts to update the BIOS so far e.g. to the transition version (v151) or earlier versions above 119 but below 151 have been unsuccessful. I have used the .exe and F7 (bootup) methods with no success. I have also tried removing the yellow BIOS config jumper to but the board into BIOS recovery mode but this also failed.

After reviewing all the current BIOS settings and I cannot see anything that would prevent a BIOS update from being applied.

The machine is running Windows 10 with Defender disabled in deference to ESET Smart Suite. Can anyone shed any light on why this board wont accept a BIOS update?

Yours in hope
Bryn
Bryn BallIT ManagerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

nobusCommented:
i would first use the Bios recovery, to be sure  i can rollback :  https://www.intel.com/content/www/us/en/support/articles/000005630/boards-and-kits.html             does that work?
is the bios battery in good shape?  it should read 3V min - you can replace it for about 1$, CR2032 model
you said updates were unsuccessfull - any messages or errors? post them please, text or picture
0
Bryn BallIT ManagerAuthor Commented:
Thanks nobus
Any text displayed is momentary so I cannot catch what it says.
CMOS battery is ok and I have tried with no devices plugged in including hd optical d just keyboard and mouse but no luck.
0
nobusCommented:
>>  Any text displayed is momentary so I cannot catch what it says.   <<  even wit h a camera?  film it
0
Challenges in Government Cyber Security

Has cyber security been a challenge in your government organization? Are you looking to improve your government's network security? Learn more about how to improve your government organization's security by viewing our on-demand webinar!

Bryn BallIT ManagerAuthor Commented:
That's the sort of thing I usually think of but not this time. Kudos to you nobus. Brilliant idea. I will do that.
0
Bryn BallIT ManagerAuthor Commented:
Hi nobus

Great idea. I videoed the process and paused when the message flashed past. The system successfully prepares the images for
- Intel Management Engine
- backup recovery firmware
- memory initialization firmware
- recovery firmware
- main firmware

but stalls (fails and reboots) when it tries to flash the Intel Management Engine firmware

Still no idea how to overcome the problem but maybe this information will helpScreenshot of message...

Thanks
Bryn
0
Bryn BallIT ManagerAuthor Commented:
Its Friday the 13th and boy this is one day I should have left the issue alone.


Another attempt succeeded in flashing part of the image then fell over.

Recovery Bios load to the original bios version #119 is unsuccessful using CD and USB approaches.

Maybe a brick has been made. :-((
0
nobusCommented:
it starts looking so
did it boot ok before?    and now??
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Bryn BallIT ManagerAuthor Commented:
Thanks for your help nobus. I have written this board off as a "brick" and sourced a updated 1155 socket version that will do the trick.
0
Bryn BallIT ManagerAuthor Commented:
Not an easy one to solve :-(( but persistence is always appreciated.
0
nobusCommented:
too bad it ends that way
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 10

From novice to tech pro — start learning today.