Exchange 2013 VSS writers missing

i'm in the middle of migration from  Ex2007 to ex2013.
Migrated test account and created couple of migration jobs.
Everything seems ok but on Ex2013 Exchange VSS writers keeps vanishing.
I'm using BackupExec and will not finish migration until i sort the backup, i have found out that after restarting Exchange Replication service i'm having writers back for a while but then i came back another morning with another failed job because exchange writer went missing.

anyone had the same experience?

Windows Server 2012 R2
Exchange 2013 CU20
oompaloompaAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Sunil ChauhanConsultant Commented:
have seen this issue multiple time, restarting the information restore service fixed the issue for me, if you have DAG setup then move the active DB on a different Node and then restart the service.
oompaloompaAuthor Commented:
not for me, i have already tried restarting whole server, exchange writer came back for a while....
not a DAG, simple one server configuration
Sunil ChauhanConsultant Commented:
probably then check for the old vss shadows and try cleaning them.

VSSadmin list shadows
Price Your IT Services for Profit

Managed service contracts are great - when they're making you money. Yes, you’re getting paid monthly, but is it actually profitable? Learn to calculate your hourly overhead burden so you can master your IT services pricing strategy.

oompaloompaAuthor Commented:
no old vss shadows...
Shreedhar EtteTechnical ManagerCommented:
Yes, Exchange VSS Writer give issues.

Please make sure "Disable Exchange Writer" registry key to a value of 0 at HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Let us know What version of BackupExec you are using?
Shreedhar EtteTechnical ManagerCommented:
Also verify the below registry value as well
Check that the registry key is enabled on the Exchange server   HKEY_LOCAL_MACHINE\Software\Microsoft\ExchangeServer\v14\Replay\Parameters\EnableVSSWriter = 1
and then restart the Microsoft Exchange Replication Service on the Exchange server
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.