Link to home
Start Free TrialLog in
Avatar of techdrive
techdriveFlag for United States of America

asked on

Remote desktop over cisco vlans

I managed to setup a test lab with 3 to 4 different vlans using a cisco router and a cisco switch. I can ping ALL remote hosts fine but when I try to use remote desktop from one windows machine to another on a different vlan it times out and doesn't allow me to access that server. On the network I am connected to 10.46.72.x it works fine if I rdp to another machine but when I am on a different vlan this doesn't work. I am using a cisco 3750 24 port and a 1900 series router. Are there any commands to use to allow for the vlans to talk to each other. I am also new at configuring cisco equipment please have mercy on me <SMILE>


                                                                                                       cisco switch 3750

SW1#sh running-config
Building configuration...

Current configuration : 3167 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname SW1
!
enable password xxxxx
!
no aaa new-model
switch 1 provision ws-c3750e-24td
system mtu routing 1500
ip subnet-zero
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
interface FastEthernet0
 no ip address
 shutdown
!
interface GigabitEthernet1/0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet1/0/2
 switchport access vlan 52
 switchport trunk encapsulation dot1q
 switchport mode access
!
interface GigabitEthernet1/0/3
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet1/0/4
!
interface GigabitEthernet1/0/5
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet1/0/6
!
interface GigabitEthernet1/0/7
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet1/0/8
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet1/0/9
 switchport mode access
!
interface GigabitEthernet1/0/10
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet1/0/11
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet1/0/12
 switchport access vlan 40
 switchport mode access
!
interface GigabitEthernet1/0/13
 switchport access vlan 50
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet1/0/14
 switchport access vlan 10
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 10,20,50-52
 switchport mode access
!
interface GigabitEthernet1/0/15
 switchport access vlan 50
 switchport mode access
!
interface GigabitEthernet1/0/16
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet1/0/17
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet1/0/18
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet1/0/19
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet1/0/20
 switchport access vlan 50
 switchport trunk encapsulation dot1q
!
interface GigabitEthernet1/0/21
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet1/0/22
 switchport mode access
!
interface GigabitEthernet1/0/23
!
interface GigabitEthernet1/0/24
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet1/0/25
!
interface GigabitEthernet1/0/26
!
interface GigabitEthernet1/0/27
!
interface GigabitEthernet1/0/28
!
interface TenGigabitEthernet1/0/1
!
interface TenGigabitEthernet1/0/2
!
interface Vlan1
 ip address 10.46.72.5 255.255.255.128
!
interface Vlan10
 no ip address
!
interface Vlan50
 no ip address
!
interface Vlan51
 no ip address
!
interface Vlan52
 no ip address
!
ip default-gateway 10.46.72.4
ip classless
ip http server
ip http secure-server
!
!
control-plane
!
!
line con 0
 password xxxxx
 login
line vty 0 4
 password xxxx
 login
line vty 5 15
 password xxxxx
 login
!
end


                              router cisco 1900


R1#show running-config
Building configuration...

Current configuration : 1843 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$c67b$DYS2AFuOVJ4teWFz02Nrh.
enable password
!
no aaa new-model
!
resource policy
!
!
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0
 ip address 10.46.72.1 255.255.255.128
 duplex auto
 speed auto
!
interface FastEthernet1
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet1.10
 encapsulation dot1Q 10
 ip address 10.10.0.1 255.255.255.128
 no snmp trap link-status
!
interface FastEthernet1.20
 encapsulation dot1Q 20
 ip address 10.20.0.1 255.255.255.128
 no snmp trap link-status
!
interface FastEthernet1.47
 encapsulation dot1Q 47
 ip address 10.47.0.1 255.255.255.128
 no snmp trap link-status
!
interface FastEthernet1.48
 encapsulation dot1Q 48
 ip address 10.48.0.1 255.255.255.128
 no snmp trap link-status
!
interface FastEthernet1.50
 encapsulation dot1Q 50
 ip address 10.50.0.1 255.255.255.128
 no snmp trap link-status
!
interface FastEthernet1.51
 encapsulation dot1Q 51
 ip address 10.51.0.1 255.255.255.128
 no snmp trap link-status
!
interface FastEthernet1.52
 encapsulation dot1Q 52
 ip address 10.52.0.1 255.255.255.128
 no snmp trap link-status
!
interface BRI0
 no ip address
 encapsulation hdlc
 shutdown
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
!
interface FastEthernet5
!
interface FastEthernet6
!
interface FastEthernet7
!
interface FastEthernet8
!
interface FastEthernet9
!
interface Vlan1
 no ip address
!
!
!
no ip http server
no ip http secure-server
!
firstshot.JPG
ASKER CERTIFIED SOLUTION
Avatar of lruiz52
lruiz52
Flag of United States of America image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of techdrive

ASKER

Sorry I didn't add this in 10.46.72.4. I am using a SOHO router and this comes in from the ISP. 10.46.72.1 is the routers interface on the cisco router and the other ones are the sub interfaces. I used static routes to connect this to my cisco switch and cisco router. Thanks for looking .
Avatar of Chris Geraghty
Chris Geraghty

On the 1900 check that routing is enabled
"ip routing" isn't visible in your config ( though it might be a default )

Is the 1900 able to ping hosts across interfaces;  eg ping device in VLAN20 from source interface in VLAN10