can not unmount Machintosh HD

Bill Doherty
Bill Doherty used Ask the Experts™
on
I attempted to recover to different system from Apple Time Machine it eventually failed due to a untimely network error. Now I can not umount disk on the targeted machine. When I say I can not unmount it I mean I CAN NOT unmount it no matter what approach I use:
Disk utility -- no
Recover -- no
terminal -- no
force via terminal --no
set as a target disk -- no

terminal commands tried were unmout, unmountDisk, unmountVolume
when using recovery on target machine terminal returns the command "no such command"   (so terminal is currupt?)
I have tried all the logical options Google has presented me, I am hoping someone here has a different solution.
Thanks
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Senior Network Systems Specialist
Commented:
The correct command is umount (not unmount) followed by the mount path.
Distinguished Expert 2017

Commented:
to unmount the drive/partition without regard to it still being used, i.e. there is a terminal, finder window that holds it...
umount -f mount_point
i.e. if you mounted the drive as /mnt
umount -f /mnt will dislodge the drive...
Though  I would suggest you check whether there is a timemachine restore still going, finder directory open on that path, or a terminal window in /mnt.....
Another sure fire way is to reboot.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial