Not able to open shared folder with FreeNAS

Dear Experts,

I m not able to open SMB share with FreeNAS from Windows 10 machines. I m having a permissions issue with the SMB shares.

I can see the shared folder in the network. Yet I cannot open it. I get Access Denied.

I want the access to be without the need of a password

FreeNAS-11.1-U5

freenas ~]# ps -ax | grep smbd

92752 - Is 0:00.35 /usr/local/sbin/smbd --daemon --configfile=/usr/local/etc/smb4.conf
92763 - I 0:00.01 /usr/local/sbin/smbd --daemon --configfile=/usr/local/etc/smb4.conf
92764 - S 0:00.01 /usr/local/sbin/smbd --daemon --configfile=/usr/local/etc/smb4.conf 98308 0 S+ 0:00.00 grep smbd

[root@TASfreenas ~]# smbstatus



Samba version 4.7.0-GIT-de2f31198c7-FreeNAS PID Username Group Machine Protocol Version Encryption Signing ------------------------------------------------------------------------------------------------------------------------------------ ---- Service pid Machine Connected at Encryption Signing --------------------------------------------------------------------------------------------- No locked files [root@TASfreenas ~]#

Thank you
marceloNYCMiddle-Tier AdministratorAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Shaun VermaakTechnical Specialist/DeveloperCommented:
What version of SMB are you using on FreeNAS? Windows 10 probably not connecting because it is SMB v1
0
marceloNYCMiddle-Tier AdministratorAuthor Commented:
SMB4 ...
0
Shaun VermaakTechnical Specialist/DeveloperCommented:
I doubt it. AFAIK SMB is at v3.1.1

Follow this as a test
Within the latest “Windows 10 Fall Creators Update” the Guest access in SMB2 is disabled by default.

You can change this setting within your group policy settings.

  1. Right click the Windows Icon at the bottom left of the task bar, or select the windows key + r
  2. Within the run box, type “gpedit.msc”
  3. Within the local Group Policy Editor, select “Administrative Templates”
  4. Select “Network”
  5. Select ”Lanman Workstation”
  6. Double click “Enable Insecure guest logons” option
  7. Tick the “Enable” option
  8. Select OK
https://forums.freenas.org/index.php?threads/do-you-have-problems-accessing-freenas-with-windows-10.62487/
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
marceloNYCMiddle-Tier AdministratorAuthor Commented:
Thank you so much I am going to try this!

Have a great rest of the weekend
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
FreeNAS

From novice to tech pro — start learning today.