Should I disable '8dot3namecreation' on Server 2008 r2 and Server 2012 r2?

I created a .dbf file and saved it to a network share on our file server (Server 2008 r2) today and got an error when I tried opening it. I created a different .dbf file a few days ago and saved it to the same network share and had no trouble opening it then. When I tried opening that same file today, it also gave me the same error.

One thing I noticed was that the files had long names. So I tried shortening the filenames and they opened up just fine.

I'm guessing it's got something to do with '8dot3namecreation'. So I queried 'disable8dot3' and saw that the current value was set to '2'. But the problem is that I don't think it was set to '2' before today. Is it safe to disable '8dot3namecreation'? I don't think we have any legacy software that uses short names, but I'm not 100% sure.

Also, I think our file server is synced to our primary server (Server 2012 r2). So I don't know if disabling 8dot3 on the file server would reflect on the primary server.

Just a quick background. Our file server used to be our primary but we added a new server to replace it. We migrated the DHCP and AD to the new one and left the File Services Role activated on the old one. The new one also has the File Services Role activated, and has the 8dot3 set to '2'. We never changed the 8dot3 on the new one and maybe the old one replicated that setting today, that's why I'm having trouble with long filenames.

I can provide more info if necessary. Please advise.
ramAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

65tdRetiredCommented:
0
Dr. KlahnPrincipal Software EngineerCommented:
One thing I noticed was that the files had long names. So I tried shortening the filenames and they opened up just fine.

Some programs are not capable of dealing with long fully-qualified filenames.  Try opening the file with several different programs (doesn't matter whether the program can deal with the file, just try to open it.)  If the open fails only in one particular program, it's an issue in that program's filename handling.

On general principles, try to keep fully-qualified filenames, including path, to 63 characters or less.  This seems to be a workable limit for most software including 32-bit legacy.
0
ramAuthor Commented:
Thanks 65td and Dr. Klahn for replying.

65td, thanks for the link. I read the article and I'm curious if I can just leave the files that have 8dot3 names when I disable 8dot3?

Dr. Klahn, I tried opening the .dbf files using three different applications and only one worked. Does that mean it's the application and not the file?
0
Dr. KlahnPrincipal Software EngineerCommented:
Dr. Klahn, I tried opening the .dbf files using three different applications and only one worked. Does that mean it's the application and not the file?

Well ... there might be some other reason, but that does tend to point at an excessively long filename.  I can't think of any other reason for that behavior if each program was given the exact same name as input.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
NTFS

From novice to tech pro — start learning today.