Windows BIOS time resetting to specific dates and times, cause unknown.

Hi EE,

I have a peculiar problem, to say the least. Let me describe the environment:

- Windows IoT devices connect to SQL server to sync their date/time which is done by query
- When the IoT devices can't connect to the network, they revert to their BIOS date/time

We have series of Windows IOT devices running Windows 10 Embedded when they lose wireless network connectivity which infrequently happens they revert to the bios date/time.
However, the bios date/time is always out of sync and from prior analysis points seems to be set to last time the Windows ICD shell was disabled when configuration changes were made to the system.

Any ideas what could be causing this any help is greatly appreciated.

Thank you.
ZackGeneral IT Goto GuyAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

first thing to do is check the bios battery - if it is a CR2032 model - should be 3 V min
ZackGeneral IT Goto GuyAuthor Commented:
Hi Nobus,

Do mean use this command:  powercfg -energy? Also, the bios time isn't resetting to the manufacturer's date, just the last date/time the shell was disabled from what I can tell.

Thank you.
ZackGeneral IT Goto GuyAuthor Commented:
Hi Nobus,

Scratch that earlier comment about powercfg -energy that is laptop batteries useless. I can't get physical access to the boxes in any case for quite some time any other thoughts?

Thank you.
Exploring ASP.NET Core: Fundamentals

Learn to build web apps and services, IoT apps, and mobile backends by covering the fundamentals of ASP.NET Core and  exploring the core foundations for app libraries.

Zack, there used to be a bug in windows 10 v1607 that made devices revert to the time they were set up.
The solution back then was to deactivate the windows time service (set it startup type to disabled) and use other means of setting the time, like commands:
net time /set /y

Open in new window

(Time server needs to be configured, else, the domain controller is used on domain joined machines)

To deactivate the startup type of the dime service, use these commands:
net stop W32Time

Open in new window

sc config W32Time start= disabled

Open in new window

(See )
ZackGeneral IT Goto GuyAuthor Commented:
Hi Mcknife,

Do you have a link to a Microsoft article pointing to this issue? Thank you very much for the post, what I will do when I get on site next is re-register the time service using the commands:

net stop w32time
w32tm /unregister
w32tm /register
net start w32time

Thank you
Why would you want to un- and re-register it? No reason for it.
Sorry, no link to microsoft resources. Back then (when 1607 came out) it was discussed at many locations on the internet, see for example (use browser translation features).

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ZackGeneral IT Goto GuyAuthor Commented:
Hi Mcknife,

My apologies for the delay I finally managed to access to these machines and we upgraded the OS. The issue no longer occurring :)

Thank you very much for the help.
You are welcome.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today

From novice to tech pro — start learning today.