Cant connect to a CRM Online organization to develop a fetchxml report

apollo7
apollo7 used Ask the Experts™
on
I am using Visual Studio 2013 and trying to connect to a CRM Online organization to develop a fetchxml report.  I have tried the unique organization URL (https://unique_org_name.crm.dynamics.com) from Settings / Developer Resources and also the URL that opens the organization online.  

Both URLs fail at the login form and cant connect.  I get the error below:

Unable to connect to data source 'DataSource1'.The connection to server "https://org123456.crm.dynamics.com " could not be established. Make sure that the connection string and credentials are correct, and try again.

Please advise
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Feridun KadirPrincipal Consultant

Commented:
Have you installed the reporting authoring tool? In the dataset you need to specify the type of the datasource as Dynamics 365 Fetch. But you won't see that option untill the reporting authoring tool is installed.

Author

Commented:
Yes, I using VS 2013 with the SQL Server Data Tools and Microsoft Dynamics CRM 2016 Report Authoring Extension installed.

After I enter the Fetchxml connection string and credentials, I am prompted with the login form and organization page over and over.  I am using the  credentials that I use to access the CRM Online organization.  

I have tried  https://orgname.crm.dynamics.com/main.aspx and the Unique Organization Name from Customizations / Developer Resources  https://uniqueorg.crm.dynamics.com/
PMI ACP® Project Management

Prepare for the PMI Agile Certified Practitioner (PMI-ACP)® exam, which formally recognizes your knowledge of agile principles and your skill with agile techniques.

Principal Consultant
Commented:
Hmm. I have a recollection that I had to update the report authoring extension to get it to work. Using the org URL as https://orgname.crm.dynamics.com should work (without the main.aspx).

Yes, on my system I'm using version 9.0.2.426 which is available here, https://www.microsoft.com/en-us/download/details.aspx?id=56973

Try that and if it helps. I think it has something to do with Microsoft enforcing TLS1.2.

Author

Commented:

I downloaded and ran it, got an error

Error
Feridun KadirPrincipal Consultant

Commented:
Did you install the previous version first?

Author

Commented:
I have version 8.2.0002.0248 installed, then I ran the update
Feridun KadirPrincipal Consultant

Commented:
According to the link I posted above, under Install Instructions, it states to uninstall previous versions.

Author

Commented:
Uninstalled the 8.2.0002 version and ran the update, got the error and went to the log file indicated:

13:06:13|  Error| Patch file is not valid for installing package. (PackageValidator.cpp:CWindowsInstallerPatchPackageValidator::Validate:364).
13:06:13|   Info| Expected parameters for update file: 
		Upgrade code - {3315FF72-9F24-423B-B854-7EDCF3394F50}
		Product code - {0C524DF0-0409-0090-BF3E-80D80B490D53}
		ProductLanguage - 1033
		BaseVersion - 9.0.2.426
13:06:13|   Info| Error not a valid MSP file - C:\Users\dtripp\Update\Bids_KB4010816_I386_1033.msp
13:06:13|  Error| The update file is not valid for installation of this application. (Setup.cpp:CCrmSetup::RetrieveUpdateFilePath:1186).
13:06:13|   Info| Clean up the BITS downloader.

 

Open in new window

Feridun KadirPrincipal Consultant

Commented:
That's odd. Is the error the first thing that appears?  Do you get the "Welcome to Microsoft Dynamics Report Authoring Extension Setup" page?

Perhaps you need to restart your PC after removing the 8.0 version?

Author

Commented:
Worth a try, brb

Author

Commented:
After rebooting, I was able to install the update.  After that, the CRM 2016 Report Authoring Extension works.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial