Cant connect to a CRM Online organization to develop a fetchxml report

I am using Visual Studio 2013 and trying to connect to a CRM Online organization to develop a fetchxml report.  I have tried the unique organization URL (https://unique_org_name.crm.dynamics.com) from Settings / Developer Resources and also the URL that opens the organization online.  

Both URLs fail at the login form and cant connect.  I get the error below:

Unable to connect to data source 'DataSource1'.The connection to server "https://org123456.crm.dynamics.com " could not be established. Make sure that the connection string and credentials are correct, and try again.

Please advise
LVL 1
apollo7Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Feridun KadirPrincipal ConsultantCommented:
Have you installed the reporting authoring tool? In the dataset you need to specify the type of the datasource as Dynamics 365 Fetch. But you won't see that option untill the reporting authoring tool is installed.
Feridun KadirPrincipal ConsultantCommented:
apollo7Author Commented:
Yes, I using VS 2013 with the SQL Server Data Tools and Microsoft Dynamics CRM 2016 Report Authoring Extension installed.

After I enter the Fetchxml connection string and credentials, I am prompted with the login form and organization page over and over.  I am using the  credentials that I use to access the CRM Online organization.  

I have tried  https://orgname.crm.dynamics.com/main.aspx and the Unique Organization Name from Customizations / Developer Resources  https://uniqueorg.crm.dynamics.com/
HTML5 and CSS3 Fundamentals

Build a website from the ground up by first learning the fundamentals of HTML5 and CSS3, the two popular programming languages used to present content online. HTML deals with fonts, colors, graphics, and hyperlinks, while CSS describes how HTML elements are to be displayed.

Feridun KadirPrincipal ConsultantCommented:
Hmm. I have a recollection that I had to update the report authoring extension to get it to work. Using the org URL as https://orgname.crm.dynamics.com should work (without the main.aspx).

Yes, on my system I'm using version 9.0.2.426 which is available here, https://www.microsoft.com/en-us/download/details.aspx?id=56973

Try that and if it helps. I think it has something to do with Microsoft enforcing TLS1.2.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
apollo7Author Commented:

I downloaded and ran it, got an error

Error
Feridun KadirPrincipal ConsultantCommented:
Did you install the previous version first?
apollo7Author Commented:
I have version 8.2.0002.0248 installed, then I ran the update
Feridun KadirPrincipal ConsultantCommented:
According to the link I posted above, under Install Instructions, it states to uninstall previous versions.
apollo7Author Commented:
Uninstalled the 8.2.0002 version and ran the update, got the error and went to the log file indicated:

13:06:13|  Error| Patch file is not valid for installing package. (PackageValidator.cpp:CWindowsInstallerPatchPackageValidator::Validate:364).
13:06:13|   Info| Expected parameters for update file: 
		Upgrade code - {3315FF72-9F24-423B-B854-7EDCF3394F50}
		Product code - {0C524DF0-0409-0090-BF3E-80D80B490D53}
		ProductLanguage - 1033
		BaseVersion - 9.0.2.426
13:06:13|   Info| Error not a valid MSP file - C:\Users\dtripp\Update\Bids_KB4010816_I386_1033.msp
13:06:13|  Error| The update file is not valid for installation of this application. (Setup.cpp:CCrmSetup::RetrieveUpdateFilePath:1186).
13:06:13|   Info| Clean up the BITS downloader.

 

Open in new window

Feridun KadirPrincipal ConsultantCommented:
That's odd. Is the error the first thing that appears?  Do you get the "Welcome to Microsoft Dynamics Report Authoring Extension Setup" page?

Perhaps you need to restart your PC after removing the 8.0 version?
apollo7Author Commented:
Worth a try, brb
apollo7Author Commented:
After rebooting, I was able to install the update.  After that, the CRM 2016 Report Authoring Extension works.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Dynamics

From novice to tech pro — start learning today.