How to disable IPv6 from all network adapters on a Windows 7 Pro. computer?

How can I completely disable IPv6 from all network adapters on a Windows 7 Pro. computer?  The use this method to roll-out that configuration change to hundreds of computers?  Is there perhaps a script?

What I am looking for is to disable or un-check the ipv6 settings.

ipv6_1
I want it to be grey'd out or disabled.

ipv6_2
According to web page: https://techjourney.net/disable-turn-off-ipv6-support-in-windows-10-8-1-8-7-vista/

I have tried opening a command prompt as administrator and running
reg add "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip6\Parameters" /v DisabledComponents /t REG_DWORD /d 0x000000FF /f

Open in new window


But after I run this command I think IPv6 is disabled partly; but, I still see the check mark on the adapters indicating that it is still enabled.  

Question1: How can I disable the ipv6 for all adapters on a windows 7 Pro. PC?  My manager specifically asked me to do the un-check box, to make it look disabled.

Question2:  How can I use that method for a mass deployment to change the config on hundreds of devices?

Question3:  How can I verify that IPv6 is indeed disabled?

Before the registry changes, if I ran an ipconfig all, under "Ethernet adapter Local Area Connection"  I saw
IPv4 Address. . . . . . . . . . . :  ###.##.##.###
Then I saw
DHCPv6 Client DUID. . . . . . . . : ##-##-##-##-##-##-##-##-##-##-##-##-##-##

After the Registry changes, I do not see any reference to DHCPv6 Client DUID. . . . . . . . : ##-##-##-##-##-##-##-##-##-##-##-##-##-##
LVL 1
PkafkasNetwork EngineerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JohnBusiness Consultant (Owner)Commented:
Why?  IPv6 is here to stay. It does not cause any issues on a properly set up machine and does not need to be removed.
Rob WilliamsCommented:
I agree with John, why.  You can actually 'break' things.  
Disabling in TCP/IP properties doesn't accomplish the task it leaves it broken,  You have to disable in the registry, which you could push out by GPO.
https://support.microsoft.com/en-us/help/929852/guidance-for-configuring-ipv6-in-windows-for-advanced-users

Again, why?
It hasn't been a problem since before XP SP3
JohnBusiness Consultant (Owner)Commented:
We have not had to disable IPv6 at any of all our clients for any reason.
Rob WilliamsCommented:
Sorry your line of code didn't display earlier in a non-full screen window.

IPv6 is actually preferred with server 2008 R2 and newer and Exchange definitely will prefer it if not require it.  There can be some security concerns with IPv6 if your ISP supports it and you don't have if configured.  If that is the case much better to block it at the router rather than on all internal devices.
PkafkasNetwork EngineerAuthor Commented:
The reason why is because we use Citrix NetScaler and tehre are doucmented problems with NetScaler and ipv6.  The registry had (from dos)

reg add "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip6\Parameters" /v DisabledComponents /t REG_DWORD /d 0x000000FF /f
JohnBusiness Consultant (Owner)Commented:
Look at this NetScaler article to help it co-exist with IPv6

https://support.citrix.com/article/CTX119961
PkafkasNetwork EngineerAuthor Commented:
Is there a way to disable ipv6 on a workstation?
JohnBusiness Consultant (Owner)Commented:
Here is the authoritative article you need.

https://support.microsoft.com/en-ca/help/929852/guidance-for-configuring-ipv6-in-windows-for-advanced-users

But look at the NetScaler article as well as no real need to do this.
masnrockCommented:
What version of NetScaler do you have? You should be able to upgrade the release that's installed to fix your issues: https://support.citrix.com/article/CTX228710
Shaun VermaakTechnical SpecialistCommented:
Are you experiencing the issues from the documented cases?

I would not take it on face value especially if it means I have to change the whole environment to fit them
PkafkasNetwork EngineerAuthor Commented:
Hello John,

Thank you but I have already referenced the web page you suggested: https://support.microsoft.com/en-ca/help/929852/guidance-for-configuring-ipv6-in-windows-for-advanced-users

Masnrock, we are  using version 12.0.56.20.  I just sent the upgraded package to the computers yesterday and 5 had a Blue Screen of death.  Ofcourse hundreds of others are fine (no BSOD).  It was suggested that the IPv6 may have something to do with it.
masnrockCommented:
57.24 contains fixes for an IPv6 issue, but I also recommend that you read the rest of the fixes in the list and assess which of the other situations have applied (situation involving BSOD is in the list as well). However, at the end of the day, you're going to have to do what's best for your situation.

https://docs.citrix.com/content/dam/docs/en-us/netscaler/12/downloads/release-notes-12-0-57-24.html

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Rob WilliamsCommented:
If you do want to push out the registry edit you can use group policy and Computer Configuration | Policies | Windows settings | Registry, and add your key.

Alternatively you can download and add ADMX files to add group policy management of IPv6 and its related features
http://www.expta.com/2009/02/how-to-configure-ipv6-using-group.html
 |
JohnBusiness Consultant (Owner)Commented:
You might wish to contact Citrix Support. They should have a solution for you
PkafkasNetwork EngineerAuthor Commented:
Interesting to note, from masnrock's web page: https://docs.citrix.com/content/dam/docs/en-us/netscaler/12/downloads/release-notes-12-0-57-24.html

In rare scenarios, blue screen appears (BSOD) when NetScaler VPN plug-in is installed along with Pulse Secure plug-in.
[From Build 51.24]
[# 683009]

introduced in version 12.51.24 That would explain why this never happend with the previous version 11.0
PkafkasNetwork EngineerAuthor Commented:
Since we use Novell Netware in our environment and ZENworks to deploy software programs and configuration settings (scripts)  Using Group Policy is not an option.  Unless it wasn't during previous Microsoft Server families.

Our computers are in a Workgroup not a Windows Domain anyway.  According to Rob WIlliams and  the web page: http://www.expta.com/2009/02/how-to-configure-ipv6-using-group.html  Group Policy will work.

Does anyone have any other suggestions besides group policy or wil this not be an option in Windows 7 and Netware?
masnrockCommented:
You found the exact thing I was counting on you coming across in the fixes list.

Also, here's a bit from Novell (or should I be saying Micro Focus now) related to doing registry edits in ZenWorks: https://www.novell.com/documentation/zcm10/zcm10_software_distribution/data/bagi8rl.html
PkafkasNetwork EngineerAuthor Commented:
Unfortunately my experience, the registry entries do not uncheck that IPv6 option for the network adapters.
masnrockCommented:
Unfortunately my experience, the registry entries do not uncheck that IPv6 option for the network adapters.
This is correct. The registry key is for disabling IPv6 at the system level. What you're actually wanted to do is to unbind IPv6 from all of your network adapters. You should be able to do it via PowerShell. And there was a utility written that would be able to help achieve this (but note that it is an unsupported application): https://gallery.technet.microsoft.com/Hyper-V-Network-VSP-Bind-cf937850
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking

From novice to tech pro — start learning today.