We help IT Professionals succeed at work.

Not receiving email from foreign client

172 Views
Last Modified: 2019-08-22
Have a weird issue where we are not receiving emails from a foreign client (client is based in South Korea, we are US based) to our main DOMIAN.COM email accounts which are an Office 365 setup. We, however, are receiving emails from this client to our backup, DOMAIN.NET, account which is Google setup. Our client will send an email to the .COM address and copy the .NET address. We will receive the email in the .NET account. Checking the spam filters and log files there is no indication that the email ever reaches the O365 server meaning we would never know it was sent without the .NET backup.

I have checked the MX records on my name server, moved to a new name server, tested my domain and cannot find a reason as to why these inbound emails will not reach the server.
Comment
Watch Question

David FavorFractional CTO
CERTIFIED EXPERT
Distinguished Expert 2019

Commented:
Try using SWAKS to send a forged text message from your client, to your server's MX record.

So send to your .com MX record + .net MX record + check SMTP conversation, to ensure all's well.

If this works, then move onto checking the differences between your .com + .net configs, so for example, if the client sending to you has incorrect SPF + DKIM DNS records setup + your .net config has looser validation settings than your .com config, then your .net will allow message submission + your .com will bounce messages.

All this is fairly simple to debug + can take a very long time + there's no way to theorize about problems.

Test messages must be sent + MTA logs checked.

If this all sounds like Greek to you, best hire someone to assist you.
timgreen7077Exchange Engineer
CERTIFIED EXPERT
Distinguished Expert 2018

Commented:
2 questions, does other senders successfully send emails to your primary domain.com email address, and does the south Korean send get any bounce backs or NDRs?
Dr. KlahnPrincipal Software Engineer
CERTIFIED EXPERT

Commented:
Sounds like (a) there is GeoIP based filtering somewhere in the primary configuration, or (b) blacklisting you don't know about.  South Korea is a notable source of spam and both are possibilities.

Have the client send you a copy of a bounced message with all routing headers showing and that will probably illuminate the problem.
David FavorFractional CTO
CERTIFIED EXPERT
Distinguished Expert 2019

Commented:
Dr. Klan makes a good point. Check both your .net + .com MTA + see if Geo blocking is turned on for one + turned off for the other.

Author

Commented:
- As far as I know, they are not getting a bounce-back email when sending to the .COM domain, but I will ask to be sure.

- I inquired about a blacklist with the email host and they said they do not have one but I will double check with them.

- I don't think it would be a GEOIP filter as we have other SK clients where this does not happen.

- I will check the SWAKS stuff over the weekend and update when I have some other answers.
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.