enable/disable systemd on ubuntu?

how to enable/disable systmctl "systemd command)?
JasaidaAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

David FavorLinux/LXD/WordPress/Hosting SavantCommented:
You can't really do this.

Disabling systemd will brick your system.

Brick == system won't work or reboot.

If you dislike systemd, then switch to using an OpenRC based Distro like Alpine.
0
Dr. KlahnPrincipal Software EngineerCommented:
I agree with  your feelings about systemd, and the first thing I do when I bring up a new Debian system is get rid of it and replace it with sysvinit.

This is a popular issue and there are numerous commentaries about it.  It's pretty simple, as detailed at the page below.  Ubuntu being built atop Debian, this should also work for your system.

http://without-systemd.org/wiki/index.php/How_to_remove_systemd_from_a_Debian_Stretch_installation

  1.     Install the sysvinit packages: apt-get install sysvinit-core
  2.    Copy inittab: cp /usr/share/sysvinit/inittab /etc/inittab
  3.    Reboot the system: reboot

I also remove cgroups, but many would consider this to be going too far.

Check to see if cgroups are active
  >mount
  If they are, disable them at boot time
  Disable kernel EFI support as well ...
  And network interface renaming ...
  >nano /etc/default/grub
    GRUB_CMDLINE_LINUX_DEFAULT="noefi net.ifnames=0 biosdevname=0 cgroup_disable=cpuset,cpu,cpuacct,blkio,memory,devices,freezer,net_cls,net_prio,perf_event,pids,systemd"
    GRUB_CMDLINE_LINUX="noefi net.ifnames=0 biosdevname=0 cgroup_disable=cpuset,cpu,cpuacct,blkio,memory,devices,freezer,net_cls,net_prio,perf_event,pids,systemd"
  >update-grub
  >reboot -s now

Open in new window

0
JasaidaAuthor Commented:
I do not have a proble or dislike  systemd. acctully i want to run stystemd, but for (i don't know) resean systemd is not working on min ubuntu 16 and when i using systemct status ssh i get error : Failed to get properties: No such interface ''
i want to enable systemd then if it's take a some mismatch with the other custom service den i want to disable it.

" sudo systemctl  daemon-reload  is not help.:-)
0
JasaidaAuthor Commented:
i reinstall systemd and reboot server. All is ok.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
David FavorLinux/LXD/WordPress/Hosting SavantCommented:
Well, likely not.

If you had to reinstall systemd, I'd say you best reinstall your entire OS from scratch.

If systemd was somehow clobbered/broken, likely many other packages may also have problems.

I suggest a full reinstall + start with Ubuntu 18 (Bionic) rather than 16 (Xenial), as Xenial is already very old.

Bionic fixes... to many things to even begin naming, over Xenial.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.