Can't browse shared folders off Windows 2003 Server

sglee
sglee used Ask the Experts™
on
Shared Folder Listing inside IIS computerBrowsing by computer name - FailedBrowsing by IP address - FailedFirewallHi,
 
 I have a domain joined Windows 2003 Server (computer name: iis, IP address: 192.168.1.4).
 All of a sudden, I can't list shared folders off that computer anymore. I used to be able to do that.
 When I log in to IIS computer and enter \\IIS or \\192.168.1.4, then I get the listing of the shared folders (please see the screenshot)
 From any computer on the same network, I can PING that computer by IP address or computer name.

 Firewall is turned on and can't turn it off. It must be controlled by the DC.
 This computer is protected by Webroot, Malwarebytes security suite of products,

Can you help?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Distinguished Expert 2018

Commented:
What version of Windows is on the computers attempting to browse? It could be related to the fact that SMB1 isn't present on the workstations.

Author

Commented:
@masrock
I am observing failures only on Windows 10 computers.
I tried Windows 2008, Windows 2016 and they can see the shared folders off "IIS".
Distinguished Expert 2018

Commented:
You're going to need to install SMBv1 on your systems. It's the only version of SMB that will work on Server 2003. And by default, it isn't installed on Windows 10. Now understand that SMBv1 isn't NOT secure by any means. But until you replace the server, that's going to be your only choice.
Ensure you’re charging the right price for your IT

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Author

Commented:
Never heard of SMB stuff. How do you install that?
Distinguished Expert 2018
Commented:
It's a Windows feature that has to be enabled.

  • Search in the start menu for ‘Turn Windows features on or off’ and open it
  • Search for ‘SMB1.0/CIFS File Sharing Support’ in the list of optional features that appears, and select the checkbox next to it.
  • Click OK and Windows will add the selected feature. You’ll be asked to restart your computer as part of this process

Author

Commented:
It worked. Thanks.
Distinguished Expert 2018

Commented:
But remember, that this is a security hole that's been getting exploited. So the sooner you can replace the server and disable SMBv1 on your workstations, the better.

Author

Commented:
So this SMBv1 is required only in the situation when accessing shared folders from old OS such as Windows Server 2003?
Distinguished Expert 2018

Commented:
Or if you have devices that only work with SMBv1. Server 2008 at least uses SMBv2.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial