Windows 10 Can't Use 2nd TAP Adapter for OpenVPN

I have multiple OpenVPNs running on my updated Windows 10 workstation.  I did until they stopped working anyway.  I used to be able to get 3 TAP adapters working, then after a reboot they stopped.  I deleted all of them with "C:\Program Files\TAP-Windows\bin\deltapall.bat" and re-installed two adapters with "C:\Program Files\TAP-Windows\bin\addtap.bat."   Sadly, only the first one will connect.  A second OpenVPN connection fails with the following messages in log:

Thu Aug 23 17:01:07 2018 OpenVPN 2.4.4 x86_64-w64-mingw32 [SSL (OpenSSL)] [LZO] [LZ4] [PKCS11] [AEAD] built on Sep 26 2017
Thu Aug 23 17:01:07 2018 Windows version 6.2 (Windows 8 or greater) 64bit
Thu Aug 23 17:01:07 2018 library versions: OpenSSL 1.0.2l  25 May 2017, LZO 2.10
Enter Management Password:
Thu Aug 23 17:01:09 2018 WARNING: --ns-cert-type is DEPRECATED.  Use --remote-cert-tls instead.
Thu Aug 23 17:01:09 2018 TCP/UDP: Preserving recently used remote address: [AF_INET]100.100.100.100:1198 
Thu Aug 23 17:01:09 2018 TCP/UDP: Socket bind failed on local address [AF_INET6][undef]:1194
Thu Aug 23 17:01:09 2018 Exiting due to fatal error

Open in new window

(Actual IP Replaced above)
Note that it fails on LOCAL port 1194 -- the remote port for this connection is 1198, but it is the second connection.  There is a live connection on REMOTE PORT 1194, but I have no ide what that has to do with local port 1194.  It does not matter which adapter I delete or which remote port the VPN is on, it will connect any VPN on any adapter, but only 1 at a time.  All others fail with the above error.
I hope some expert can help, this is hurting my productions.
Thanks!
LVL 1
jrigginAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

QlemoBatchelor, Developer and EE Topic AdvisorCommented:
To properly support a multi-connection scenario you should name each TAP adapter individually and put that name into the OpenVPN config files, option dev-node.
0
jrigginAuthor Commented:
Thanks, Qlemo.

I renamed one of the adapters to "Tun2" and put "dev-node Tun2" in the .ovpn file but the result did not change.  Same error:
Fri Aug 24 08:58:32 2018 TCP/UDP: Preserving recently used remote address: [AF_INET]100.100.100.100:1198
Fri Aug 24 08:58:32 2018 TCP/UDP: Socket bind failed on local address [AF_INET6][undef]:1194
Fri Aug 24 08:58:32 2018 Exiting due to fatal error

Open in new window

0
QlemoBatchelor, Developer and EE Topic AdvisorCommented:
You've used only two connections, one without dev-node and one with?
Make sure you have the nobind option mentioned in all configs.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jrigginAuthor Commented:
Thanks!  nobind did it for me.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 10

From novice to tech pro — start learning today.