Get  error Missing activeX component  Business Explorer Global Services.  Excel 2013 SAP 750

Peter Groves
Peter Groves used Ask the Experts™
on
I'm trying to get SAP to send a report to Excel 2013 but keep getting the error Missing activeX component  Business Explorer Global Services.

Someone mentioned that this will only work with Excel 2010 , which I find odd, but then again this IS Microsoft!

What can I do other than downgrade excel to get it working?

Excel Version:       Excel  (15.0.5059)       2013
Windows Version:       Windows 7 Service Pack 1 (7601)      
Default Browser:       Internet Explorer (11.0.9600.19101)      
SAP GUI:       720 Patch 15      

Thanks

Pete
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Kyle SantosSoftware Test Analyst I at Dassault Systemes

Commented:
Hi,

I am here to help you with your open question.  Do you still need help?  I have the ability to alert more experts if you still need help.

If you solved the problem on your own, would you please post the solution here in case others have the same problem?

If you need me to delete this question just say "Delete."

Thank you for using Experts Exchange.

Regards,

Kyle Santos
Customer Relations

Author

Commented:
Well I sort of have a solution, but not one I want really. They said I have to install Excel 2010! I'll keep both installed as I only need the SAP ActiveX component occasionally!  I was going to leave the question open for a while in case someone had a solution better that the ridiculous Idea of installing an older version!

thanks

Pete

Author

Commented:
thanks

Pete
Ensure you’re charging the right price for your IT

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Software Engineer
Top Expert 2011
Commented:
Can you please confirm the version of SAP GUI you are using, question header says 750, question text says 720 patch 15.

Do you know if you have installed the 64 or 32 bit version of Office, it seems that there were some compatibility issues with the 64 bit of Office and earlier versions of SAP GUI.

From what I can see you need a least SAP GUI version 7.30 patch 3+ and that is with the 32 bit version of office 2013, but it would be better if you could migrate to SAP GUI 7.4.

https://archive.sap.com/documents/docs/DOC-29360

Author

Commented:
OK , just checked , it is the 720 patch 15 that is correct and the version of office is 32bit!

Migration to a higher level is out of the question, so I guess rolling back my Excel to 2010 is the only real solution for now!

Thanks

Pete
Kyle SantosSoftware Test Analyst I at Dassault Systemes

Commented:
Great!  Sounds like this problem is solved.  Would you like help closing this question or do you got it on your end?

Author

Commented:
Thanks guys!  I put in a request to install Office 2010 but the IT group said it was discontinued and have to put in a SPECIAL request for non standard software which I was told will take a month! LOL

I'll see if I can hurry thing along!

Pete

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial