Windows 7 pro setup program disables USB keyboard and mouse

I have seen other issues similar to this referenced on web and have one workaround.
But I'd like to know if anyone has encountered this and if you have a fix for it.

New system needing OS to install on SSD. Attempting to install Windows Professional 7 but after setup program expands and runs the keyboard and mouse (KB&M) power are disabled. They are OK otherwise (ie if checking EUFI/BIOS or booting alternate OS such as Linux).

- System BIOS is up to date
- Latest ISO image is being used
- USB2 ports are used for KB&M but USB3 makes no difference
- Legacy boot settings are OK
- Same issue regardless of USB or DVD boot to installer
- Issue is 100% reproducible

Anyone experience this and get past it using USB KB&M??
LVL 2
DanielTAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JohnBusiness Consultant (Owner)Commented:
No.  And we use these.

Go to Device Manager, the USB Section and update USB Drivers.
0
DanielTAuthor Commented:
Hi John,

There is no OS, as described.
KB&M are OK until Setup presents the first user screen which is for Language Selection but at that point there is no keyboard or mouse control.

Thanks
0
JohnBusiness Consultant (Owner)Commented:
Try a different Windows DVD - Maybe the Recovery DVD from the Vendor for that machine.
0
Newly released Acronis True Image 2019

In announcing the release of the 15th Anniversary Edition of Acronis True Image 2019, the company revealed that its artificial intelligence-based anti-ransomware technology – stopped more than 200,000 ransomware attacks on 150,000 customers last year.

William FulksSystems Analyst & WebmasterCommented:
What kind of keyboard and mouse are you using? Maybe try a different set if you have one available. Sounds like some kind of driver issue.

Also, sometimes it takes Windows a minute or so to recognize the keyboard and mouse then install drivers. Have you let it sit for a bit and see if it's just waiting to install drivers?
1
DanielTAuthor Commented:
John,
Good suggestion. DVD had been around so I downloaded new ISO.
No difference. Same Symptoms.

William
Standard Logitech KB.
Have tried alternate KB too, yes.
Despite USB2 being best ports, tried USB3 as well - no difference.

This is from Windows Setup ISO (DVD or USB - does not matter) so no way to "load" drivers.
Linux boot works fine from a DVD.
Even an older Ubuntu 12 release.

But Windows 7 pro setup "shuts off" the USB power, so to speak.
LED on KB goes out, as does the mouse tracking LED.
0
DanielTAuthor Commented:
ONE solution (although not sure if a full install will work) is that a PS2 keyboard is still powered and will allow setup to continue. Problem is - down the road this may not be a possible workaround. Surprised I had one as it is!! LOL
0
fred hakimRetired ITCommented:
This is pretty much a standard symptom of  trying to use a USB 3.0 port for installation.  You say you tried USB 2.0 ports and that failed too, so I'll trust you on that one.

A couple possibilities.  !st, you may have bios settings to manage how USB ports act with an OS.  Check those and make sure the bios is set to enable the USB ports natively -- can't give the setting exactly, because we don't know the PC make and model.  

If that fails, you may need to add USB drivers to your windows install USB, the base install accommodates most, but not all USB controllers.  You need to get the drivers from your PC OEM and add them to the installation disk.    

See:   https://community.spiceworks.com/how_to/125921-how-to-add-drivers-manually-to-usb-drive-to-install-windows-using-a-usb-3-0-port 
or:  https://docs.microsoft.com/en-us/windows-hardware/manufacture/desktop/add-device-drivers-to-windows-during-windows-setup  
or:  http://woshub.com/adding-usb-3-0-controller-drivers-to-windows-7-install-media/  

I provide many links, because I don't know PC or OS specifics.  I'm sure if you post it, someone (including me , if I have time later) can provide the specific instructions you would need.
0
DanielTAuthor Commented:
Fred.

Thanks for trusting me.
2x USB2 ports closest to network port.
Remaining "BLUE" ports above or on front of the system.

You do know OS specifics
Windows 7 Professional; attempted with two different images (previous that worked and newly downloaded with SP1 included).

System is not brand name such as HP, Dell, Lenovo.
Components are.
MS is Asus PRIME B250M-C/CSM
with latest BIOS - as I believe I mentioned.

if drivers are a problem for USB2 which should certainly not be, PS2 should certainly be a problem.

Available USB ports
0
fred hakimRetired ITCommented:
Sorry, I scanned back up quickly to see about the PC, and totally missed the Windows 7 Pro, while I was up there.  

I checked the ASUS site  They have drivers and manuals for the Prime B250M-C

See:  https://www.asus.com/Motherboards/PRIME-B250M-C/HelpDesk_Download/  

They also have a Windows 7 setup guide which states you need the USB drivers to load Windows 7 and provides instructions on how to do that.  

See:   https://dlcdnets.asus.com/pub/ASUS/mb/LGA1151/PRIME_B250M-C/DE170_Windows_7_Setup_Guide_web.pdf

Note:  USB has nothing to do with the PS/2 ports and your PS/2 keyboard may work well enough to get windows loaded on the system.  You could then download and burn a CD (from another PC) with the LAN,  USB, and chipset drivers to copy over and install.  That would be enough to get whatever else you need downloaded.   While your downloading stuff  (from another PC) , you can save some more time creating an WSUS offline USB to get windows 7 updated quicker.  

See:  http://download.wsusoffline.net/
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
DanielTAuthor Commented:
Hey Fred,

NP.
Thanks!
Happens to me all the time too as I "skim".

Will have to check this out.
Answers the question(s) of how to get the drivers to load DURING setup.

I must say I would not have given a lot of attention to it, as it seemed to be for preloading USB3 drivers and would have expected USB2 to be fine. BUT in a closer read the first sentence certainly seems to support this is needed even though the majority of the article speaks only of USB3.

Will indeed give this a shot!
Thanks also for the links.

Looks like a GREAT help! :))
0
DanielTAuthor Commented:
Update.

The Asus PDF was inaccurate.

First problem...
There was not a runable EZ Installer on the DVD.
So I searched and found downloads for EZ Installer. Probably best anyway.
Downloaded latest and it looked quite easy to create a modified install USB.

Second problem...
It failed to complete creating a modified USB installer - just giving an error and option to exit!
Tried to boot from USB anyway and found I had mouse - possibly with no KB (no LEDs but I did not need it yet)
Install failed with missing files.
Suspect was the failed creation using EZ Installer.

Used alternate install method with my own USB that I started with and was finally able to get past the user prompt screens.
By the time I needed a KB, it was working but Windows had installed.
Confirmed the issue above was the "modified" USB created by Asus "EZ" Installer.

Issue is resolved.
I will be closing this now.

Thanks to all - but especially to Fred.
0
fred hakimRetired ITCommented:
Glad to help.  I have been there too.
0
DanielTAuthor Commented:
Awesome help from Fred.
Great Links and accurate - at least as much as vendor's own solutions worked!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows OS

From novice to tech pro — start learning today.