RDP sessions requires domain name

RDP sessions requires domain name

I am using RDP to connect to a computer. I will have each time to enter domainname\username to login.
I used to enter just username, but I do not know what has been changed, now I will have to enter DomainName too.
Any idea ?

Thank you
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Scott SilvaNetwork AdministratorCommented:
There are usually a few things that cause this...
A local account on the target with the same name
a local account on the host with the same name
The host not being in the same domain
The logged in user not being a member of the same domain
A trust issue with AD
Not being able to contact AD server and no cached credentials on host.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
I use a program, free called mRemoteNG, it's so much easier than RDP

jskfanAuthor Commented:
Not being able to contact AD server and no cached credentials on host.

it is able to contact AD DC, they can login after typing :domainname\username then password
it should cache the credentials, since user can login when they type domainname\username then password
if they log off , you would think next time they login, they should not have to  type the domainname\
just username and password
Active Protection takes the fight to cryptojacking

While there were several headline-grabbing ransomware attacks during in 2017, another big threat started appearing at the same time that didn’t get the same coverage – illicit cryptomining.

Scott SilvaNetwork AdministratorCommented:
It doesn't work that way. To work without domainname\username, you need several things.

The calling machine needs to be joined to the domain.
The user needs to be logged into that machine as a domain user
The called machine also needs to be joined to the domain
Both machines need to be able to interact enough with the network to pass kerberos tickets...

If just one is not there, you need full credentials...
Qlemo"Batchelor", Developer and EE Topic AdvisorCommented:
The RDP file allows to store the credentials. and even if the remote machine prohibits storing credentials, the user is still kept. So what is the issue with typing the full name once in the RDP (!) settings, store that (maybe in another RDP file instead of the user's Default.RDP), and have it ready?

There are security measures to prevent attacks using only the user name, that might have been the reason it does not work for you anymore. Having to know the domain makes attacks much more difficult ;-):
jskfanAuthor Commented:
Thank you Guys...
Cannot verify further the issue with the user as he is not reachable.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.