SCCM 2012 PXE boot problems

SCCM 2012, PXE boot stops working. I have SCCM version 1806.
The contact with DHCP gets the IP address, next download WDSNBP from my SCCM server.  Everything looks working fine until I got the line "Press F12 for network service boot".
 if I press F12 I got this error: " The Windows Boot Configuration Data (BCD) file from the PXE server does not contain a valid operating system entry. Ensure that the server has boot images installed for this architecture. Error code:0x0000098"
Else the computer skips the image mode and goes to Windows.
WDS has this error "The PXE server processed a request from a client of architecture x86x64.  However, there were no boot images installed for this architecture.  PXE clients of this architecture will not be able to complete the boot process successfully.  To resolve this problem, add at least one boot image for this architecture."
If I use a DVD with the boot image the image process goes through without problems.
Things that I tested:
1-Disable PXE support on Distribution points waits for the server to remove the files, reboot and re-enable PXE again.
2-Create a new boot image.
3-Create a new task sequence.
4-Remove support for unknown computers.
SmartSelect_20180828-093032_Photos.jpg
20180828_081920.jpg
LVL 1
Oscar PowersAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Mike TLeading EngineerCommented:
Hi,

You have the answer (twice): (1) Ensure that the server has boot images installed for this architecture.
and (2) The PXE server processed a request from a client of architecture x86x64
                                                                                                                                 ^^^^^^^
                                                                                                                        this bit is wrong - it is either x86 or x64.

Whichever one you have, you need the other architecture. For PXE booting you need BOTH boot architectures available on the PXE enabled DP regardless of the final OS you are deploying. Distribute the one that is missing and it will work. I am going to guess you didn't distribute the 32-bit boot WIM at a guess.

Read this article for the nitty gritty troubleshooting (including guidance to use IPHelpers)
https://blogs.technet.microsoft.com/configurationmgr/2011/01/05/troubleshooting-the-pxe-service-point-and-wds-in-configuration-manager-2007/
but the key steps are 16/17.

PXE has not changed (much) since 2007 so it all still applies perfectly.

Mike
0
Oscar PowersAuthor Commented:
Thanks, Mike.

I have both boot images one for 64 an another for 32.
IP helper is working, PC can get IP from DHCP.
About the error on  WDS  this is literal from the server log "The PXE server processed a request from a client of architecture x86x64.  However, there were no boot images installed for this architecture.  PXE clients of this architecture will not be able to complete the boot process successfully.  To resolve this problem, add at least one boot image for this architecture."
I try a x32 boot image in the task sequence but I got same error.
System was working fine Friday and Monday I have this error.
0
Mike TLeading EngineerCommented:
Hi,

OK, that changes things slightly. I have to ask now "has anything changed"? If it was working Friday it would still be working unless either someone changed something or, less likely, files corrupted on the DP.

Cause 1: someone changed on of the boot wims
Fix 1: revert to previous copy of WIMs; if no backup was made (available) go to Fix 2

Cause 2: unknown/corruption
Fix 2: delete both boot WIMs for the DP and re-distribute.

As a side note, how many drivers are in the boot WIMs? Is this a new setup or has it been going for a long time?
Best practise, especially for W10, is don't bother adding any drivers at all! The chances are high that W10 native WinPE drivers are already there and will work. Point 2 - you only need disk and network drivers. Don't add Bluetooth, wireless, audio, etc.

The point is, it might be a good time to review the boot WIMs and slim them down. The result is booting will be faster, so the end-user experience is better and just "feel" better.

I would also say PXE itself looks to be working fine - it is purely the boot WIM needing to see and recognise both architectures before it proceeds to boot with your one.


Mike
0
Powerful Yet Easy-to-Use Network Monitoring

Identify excessive bandwidth utilization or unexpected application traffic with SolarWinds Bandwidth Analyzer Pack.

Oscar PowersAuthor Commented:
I think about that but I only redo the x64 and I added the Dell WinPE drivers. I will do your plan redo both images without drivers, this Wednesday. I will let you know.  Thanks for your help.
0
Oscar PowersAuthor Commented:
I recreate both images one x64 and another x86 but I have the same error.
I used:
COPYPE.CMD x86 c:\WINPE86\
COPYPE.CMD amd64 c:\WINPE64\
WDS has these two errors:
1- "The PXE server processed a request from a client of architecture x86x64.  However there were no boot images installed for this architecture.  PXE clients of this architecture will not be able to complete the boot process successfully.  To resolve this problem, add at least one boot image for this architecture."
2- "The PXE server processed a request from a client of architecture x86.  However there were no boot images installed for this architecture.  PXE clients of this architecture will not be able to complete the boot process successfully.  To resolve this problem, add at least one boot image for this architecture."

Any other suggestion.
Boot-images.PNG
bootimage-PXE-enable.PNG
Properties-distribution-point.PNG
0
Mike TLeading EngineerCommented:
Hi,

I can see from the screenshot that you unfortunately have already deleted the default boot images from Microsoft. If you hadn't I would say use those.
As it's too late, did you follow the steps as Anders describes here?

https://www.andersrodland.com/create-sccm-boot-image-using-dism/

If not, just delete the current ones and follow those steps. WDS and PXE look fine. As you have already said everything was working, how long was it working for?

There is an excellent troubleshooting guide here:
https://blogs.technet.microsoft.com/system_center_configuration_manager_operating_system_deployment_support_blog/2011/10/14/troubleshooting-the-pxe-service-point-and-wds-in-configuration-manager-2007/

Other than that can you attach the full SMSPXE.log - redact server names if you like.

Mike
0
Oscar PowersAuthor Commented:
This system is working for three years.
Here is the SMSPXE.log
All my boot images were created after the error.  I delete all boot images created before the error.
SMSPXE.log
0
Mike TLeading EngineerCommented:
Hi,

The log shows that the MP is not happy since 10.47 with [PXE::MP_InitializeTransport failed; 0x80004005]. Maybe that's because you deleted the boot WIMs but regardless, I would suggest doing a clean up. Remove WDS completely using these steps:

1) Untick the "Enable PXE option" on the DP. Answer yes that you want to remove the Windows Deployment service.
2) Remove the boot images from your distribution point
3) After few minutes delete the contents of %windir%\temp
4) If WDS is uninstalled correctly, reboot the server.
5) Check if the remoteinstall folder is still on your system and if it is delete it. If it fails to delete due to permission issues with the SMSTempBootFiles path, delete all folders except that one and then rename the remoteinstall folder something else.
6) Reboot the server again.

Now add the PXE point back by checking the box on the DP properties. Look in the distrmgr.log log file in CMTrace and see if the remoteinstall folder is re-created.
I have seen odd issues where some of the files in the remoteinstall folder get corrupt or go missing, so it's best to remove them (using the console - don't try deleting the files manually as that will make things worse).

Now distribute the boot images again and then try PXE.

Mike
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Oscar PowersAuthor Commented:
These are are my actual steps:
1) Untick the "Enable PXE option" on the DP. Answer yes that you want to remove the Windows Deployment service.
2) Remove the boot images from your distribution point
3) After few minutes delete the contents of %windir%\temp
4)Reboot server
5)Remove WDS role
6)Reboot server
7)Delete remoteinstall folder
8)Re-install WDS role
9) Reboot the server again.
10)Add the PXE point back by checking the box on the DP properties
11)Distribute the boot images again and then try PXE.

Thanks, Mike for all your help.
0
Mike TLeading EngineerCommented:
Glad you got it working. It can be frustrating but such a relief when it's back!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
DHCP

From novice to tech pro — start learning today.