Starttls not showing on receive connector

I have a few customers with exchange 2016.  They all have a 3rd party SSL certificate and it is designated for imap, pop, iis and smtp I have the main receive connector set to do TLS but for some reason when I connect externally to port 25 with a telnet program it connects but when I do ehlo it does not show 250-starttls.  I have port 25 and 443 open to the servers is there something else I need to do to the server for it to accept incoming tls or do I need to open more ports on the firewall?
grevelsAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

PRADIIP SINGHCommented:
Sometimes it could;d be blocked at your network device may be firewall or how about internal?
0
grevelsAuthor Commented:
Is it port 25 or should there be another port open for it
0
PRADIIP SINGHCommented:
Its port 25 only but I roughly remember that there was CISCO device which can block these verbos.
0
10 Tips to Protect Your Business from Ransomware

Did you know that ransomware is the most widespread, destructive malware in the world today? It accounts for 39% of all security breaches, with ransomware gangsters projected to make $11.5B in profits from online extortion by 2019.

Michael B. SmithExchange & Active Directory ExpertCommented:
Lots of firewalls do not forward STARTTLS if they don't have the SSL certificate loaded on them. Cisco is one of them. Cisco ASA appliances implement something called "smtp inspection" that will prevent STARTTLS.

Generally you can look at the '220' header to determine whether you are talking to an Exchange server or to a firewall. Exchange looks like this:

220 Ex2019.smithcons.com Microsoft ESMTP MAIL Service ready

Followed by a datestamp. A firewall will look differently.

Generally speaking, the firewall should NAT or passthrough "without inspection" (unless you've configured it to do deep inspection in which case you wouldn't be asking this question). :-)
0
Pete LongTechnical ConsultantCommented:
Mmm my money is on the Exchange receive connector? Did you enable TLS on there? I've never needed to open another port for a StartTLS connection, and I am the LordOfCiscoFirewalls?

Pete
0
grevelsAuthor Commented:
When you said about that some loading the certificate on the firewall that made me realize our firewall does spam blocking when means that outside is talking to the firewall not directly to the email server.  which pointed me in the right direction that I have found the problem and have it fixed.  Thank you all for the thoughts on this.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Michael B. SmithExchange & Active Directory ExpertCommented:
Just FYI - you should award some points for assistance on our part. Thanks!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.