Dell online capacity expansion issue

Hi

I have a Dell R720XD running a Perc H710p raid card.

I am in the process of setting it up and want to ensure i can increase the raid capacity at some point down the line.  I have read the H710p user guide (attached) which states that if i use Raid 6 i can add more disks and do an online capacity expansion.

To make sure i have setup a Raid 6 using 4 x SAS drives.

I have then turned the server off and installed a further 4 x SAS drives (Same model and capacity).

When i then go into the raid config using either the OSMA or the CLI there is no reconfigure option or even tasks option as per the below link.

https://www.oxfordsbsguy.com/2017/11/26/how-to-expand-a-dell-perc-h710-raid-array/

The server and raid controller are running the latest bios versions.

I have also attached a screen shot of what i see in the OSMA.

Please help, thanks
poweredge-rc-h310_User-s-Guide_en-us.pdf
1.jpg
timb551IT ManagerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Sajid Shaik MSr. System AdminCommented:
check my article

https://www.experts-exchange.com/articles/19539/Raid-Conversion-on-Dell-Server.html

for the idea

just you have to follow the Image 5 in the article

all the best
5.jpg
0
timb551IT ManagerAuthor Commented:
The problem i have is that nowhere on any page is a tasks heading for me to make any changes.
0
andyalderCommented:
Have you put any data on it yet? Until the array is fully initialized some processes are deferred. You posted a photo rather than a screen shot so I suspect you have not installed an OS. Try an OS install (VMware only takes 5 minutes) and then see if the options appear.

Do you really mean CLI rather than BIOS utility? With a CLI options do not appear, you can type anything you want although you may get an error message when you press enter.
0
Newly released Acronis True Image 2019

In announcing the release of the 15th Anniversary Edition of Acronis True Image 2019, the company revealed that its artificial intelligence-based anti-ransomware technology – stopped more than 200,000 ransomware attacks on 150,000 customers last year.

timb551IT ManagerAuthor Commented:
Hi

I have installed Centos on it with a GUI but it was easier to just take a picture.

The raid does look like its all in line now but no options have appeared.  When i said CLI sorry i meant the CNTRL R option on boot to access the Raid configuration.

regards
Tim
0
andyalderCommented:
Maybe it's a "sliced" array, you can't use OCE on Dell PERCs if there are more than one logical disk on the set of spindles.
0
timb551IT ManagerAuthor Commented:
I have only setup a single raid 6 on the original 4 disks.
0
Sajid Shaik MSr. System AdminCommented:
you can log on to the machine using idrac ... check articles for idrac
https://www.dell.com/support/article/us/en/04/sln306877/dell-poweredge-how-to-configure-the-idrac-9-and-the-lifecycle-controller?lang=en

after log on the the machine using Idrac

add additional HDD's to your existing raid...

all the best
0
timb551IT ManagerAuthor Commented:
Tried through idrac and again no options or tasks are available on the drives.

I did find a very old article from 2012 that said Dell wont allow OCE with non Dell drives.

Do you know if this is the case?
0
andyalderCommented:
Never heard of that, found the article ans it says it worked for them using OMSA for Windows anyway but not in the BIOS utility.

Presumably the disks are identical capacity since their firmware is the same.
0
timb551IT ManagerAuthor Commented:
Thats right, all same brand, capacity firmware.  I must be missing something very obvious but there is no option to make and raid changes apart from adding hot spares.
0
andyalderCommented:
I could look through a DSET report for you to see if I can spot something, it's rather big but it's just zipped HTML so you can cut the irrelevant stuff out, password is just "dell" if I remember correctly.
0
andyalderCommented:
Actually "perccli /c0 show all" would do if you install the PERC CLI.
0
timb551IT ManagerAuthor Commented:
ive rebuilt the server with windows to make fault diagnosing this a little easier for me.

I have installed the cli and this is what I get when I run the command you have put



Status Code = 0
Status = Success
Description = None

Number of Controllers = 1
Host Name = WIN-APPBU3SU40D
Operating System  = Windows Server 2016 Technical Preview

System Overview :
===============

-------------------------------------------------------------------------
Ctl Model         Ports PDs DGs DNOpt VDs VNOpt BBU sPR DS EHS ASOs Hlth
-------------------------------------------------------------------------
  0 PERCH710PMini     8   8   1     0   1     0 Opt On  3  N      0 Opt
-------------------------------------------------------------------------

Ctl=Controller Index|DGs=Drive groups|VDs=Virtual drives|Fld=Failed
PDs=Physical drives|DNOpt=DG NotOptimal|VNOpt=VD NotOptimal|Opt=Optimal
Msng=Missing|Dgd=Degraded|NdAtn=Need Attention|Unkwn=Unknown
sPR=Scheduled Patrol Read|DS=DimmerSwitch|EHS=Emergency Hot Spare
Y=Yes|N=No|ASOs=Advanced Software Options|BBU=Battery backup unit
Hlth=Health|Safe=Safe-mode boot


ASO :
===

----
Ctl
----
  0
----

Cl=Cluster|MD=Max Disks|WC=Wide Cache|SS=Safe Store|FP=Fast Path|Re=Recovery
CR=CacheCade(Read)|RF=Reduced Feature Set|CO=Cache Offload
CW=CacheCade(Read/Write)|X=Not Available/Not Installed|U=Unlimited|T=Trial
|HA=High Availability |SSHA=Single server High Availability




C:\Users\Administrator>perccli /c0 show all
Generating detailed summary of the adapter, it may take a while to complete.

Controller = 0
Status = Success
Description = None


Basics :
======
Controller = 0
Model = PERC H710P Mini
Serial Number = 27300KR
Current Controller Date/Time = 09/04/2018, 15:37:24
Current System Date/time = 09/04/2018, 15:37:24
SAS Address = 5d4ae520b09d7900
PCI Address = 00:02:00:00
Mfg Date = 07/06/12
Rework Date = 07/06/12
Revision No = A01


Version :
=======
Firmware Package Build = 21.3.5-0002
Firmware Version = 3.131.05-8148
Bios Version = 5.42.00.1_4.12.05.00_0x05290003
Ctrl-R Version = 4.04-0003
Preboot CLI Version = 05.00-03:#%00008
NVDATA Version = 2.1108.03-0097
Boot Block Version = 2.03.00.00-0004
Bootloader Version = 06.253.57.219
Driver Name = percsas2i.sys
Driver Version = 6.805.03.00


Bus :
===
Vendor Id = 0x1000
Device Id = 0x5B
SubVendor Id = 0x1028
SubDevice Id = 0x1F34
Host Interface = PCI-E
Device Interface = SAS-6G
Bus Number = 2
Device Number = 0
Function Number = 0


Pending Images in Flash :
=======================
Image name = No pending images


Status :
======
Controller Status = Optimal
Memory Correctable Errors = 0
Memory Uncorrectable Errors = 0
ECC Bucket Count = 0
Any Offline VD Cache Preserved = No
BBU Status = 0
PD Firmware Download in progress = No
Lock Key Assigned = No
Failed to get lock key on bootup = No
Lock key has not been backed up = No
Bios was not detected during boot = No
Controller must be rebooted to complete security operation = No
A rollback operation is in progress = No
At least one PFK exists in NVRAM = No
SSC Policy is WB = No
Controller has booted into safe mode = No


Supported Adapter Operations :
============================
Rebuild Rate = Yes
CC Rate = Yes
BGI Rate  = Yes
Reconstruct Rate = Yes
Patrol Read Rate = Yes
Alarm Control = Yes
Cluster Support = No
BBU  = No
Spanning = Yes
Dedicated Hot Spare = Yes
Revertible Hot Spares = Yes
Foreign Config Import = Yes
Self Diagnostic = Yes
Allow Mixed Redundancy on Array = No
Global Hot Spares = Yes
Deny SCSI Passthrough = No
Deny SMP Passthrough = No
Deny STP Passthrough = No
Support more than 8 Phys = Yes
FW and Event Time in GMT = No
Support Enhanced Foreign Import = Yes
Support Enclosure Enumeration = Yes
Support Allowed Operations = Yes
Abort CC on Error = Yes
Support Multipath = Yes
Support Odd & Even Drive count in RAID1E = No
Support Security = Yes
Support Config Page Model = Yes
Support the OCE without adding drives = Yes
Support EKM = No
Snapshot Enabled = No
Support PFK = No
Support PI = No
Support Ld BBM Info = No
Support Shield State = No
Block SSD Write Disk Cache Change = No
Support Suspend Resume BG ops = No
Support Emergency Spares = No
Support Set Link Speed = No
Support Boot Time PFK Change = No
Support JBOD = No
Disable Online PFK Change = No
Support Perf Tuning = Yes
Support SSD PatrolRead = No
Real Time Scheduler = No
Support Reset Now = No
Support Emulated Drives = No
Headless Mode = Yes
Dedicated HotSpares Limited = No
Point In Time Progress = No
Extended LD = No
Boot Volume Supported = No
Support Uneven span  = No
Support Config Auto Balance = No
Support Maintenance Mode = No
Support Diagnostic results = No
Support Ext Enclosure = No
Support Sesmonitoring = No
Support SecurityonJBOD = No
Support ForceFlash = No
Support DisableImmediateIO = No
Support LargeIOSupport = No
Support DrvActivityLEDSetting = No
Support FlushWriteVerify = No
Support CPLDUpdate = No
Support ForceTo512e = No
Support discardCacheDuringLDDelete = No
Support JBOD Write cache = No
Support Large QD Support = No
Support Ctrl Info Extended = No
Support IButton less = No
Support AES Encryption Algorithm = No
Support Encrypted MFC = No


Supported PD Operations :
=======================
Force Online = Yes
Force Offline = Yes
Force Rebuild = Yes
Deny Force Failed = No
Deny Force Good/Bad = No
Deny Missing Replace = No
Deny Clear = No
Deny Locate = No
Support Power State = Yes
Set Power State For Cfg = No
Support T10 Power State = Yes
Support Temperature = Yes
NCQ = No
Support Max Rate SATA = No


Supported VD Operations :
=======================
Read Policy = Yes
Write Policy = Yes
IO Policy = Yes
Access Policy = Yes
Disk Cache Policy = Yes
Reconstruction = Yes
Deny Locate = No
Deny CC = No
Allow Ctrl Encryption = No
Enable LDBBM = Yes
Support FastPath = Yes
Performance Metrics = Yes
Power Savings = Yes
Support Powersave Max With Cache = No
Support Breakmirror = Yes
Support SSC WriteBack = No
Support SSC Association = No
Support VD Hide = No
Support VD Cachebypass = No
Support VD discardCacheDuringLDDelete = No


HwCfg :
=====
ChipRevision =  B0
BatteryFRU = N/A
Front End Port Count = 0
Backend Port Count = 8
BBU = Present
Alarm = Missing
Serial Debugger = Present
NVRAM Size = 32KB
Flash Size = 16MB
On Board Memory Size = 1024MB
CacheVault Flash Size = NA
TPM = Absent
Upgrade Key = Absent
On Board Expander = Absent
Temperature Sensor for ROC = Present
Temperature Sensor for Controller = Present
Upgradable CPLD = Absent
Current Size of CacheCade (GB) = 0
Current Size of FW Cache (MB) = 883
ROC temperature(Degree Celsius) = 57
Ctrl temperature(Degree Celsius) = 57


Policies :
========

Policies Table :
==============

------------------------------------------------
Policy                          Current Default
------------------------------------------------
Predictive Fail Poll Interval   300 sec
Interrupt Throttle Active Count 16
Interrupt Throttle Completion   50 us
Rebuild Rate                    30 %    30%
PR Rate                         30 %    30%
BGI Rate                        30 %    30%
Check Consistency Rate          30 %    30%
Reconstruction Rate             30 %    30%
Cache Flush Interval            4s
------------------------------------------------

Flush Time(Default) = 4s
Drive Coercion Mode = 128MB
Auto Rebuild = On
Battery Warning = On
ECC Bucket Size = 255
ECC Bucket Leak Rate (hrs) = 4
Restore HotSpare on Insertion = Off
Expose Enclosure Devices = Off
Maintain PD Fail History = Off
Reorder Host Requests = On
Auto detect BackPlane = SGPIO/i2c SEP
Load Balance Mode = Auto
Security Key Assigned = Off
Disable Online Controller Reset = Off
Use drive activity for locate = Off


Boot :
====
BIOS Enumerate VDs = 1
Stop BIOS on Error = Off
Delay during POST = 0
Spin Down Mode = None
Enable Ctrl-R = Yes
Enable Web BIOS = No
Enable PreBoot CLI = No
Enable BIOS = Yes
Max Drives to Spinup at One Time = 4
Maximum number of direct attached drives to spin up in 1 min = 20
Delay Among Spinup Groups (sec) = 12
Allow Boot with Preserved Cache = Off


High Availability :
=================
Topology Type = None
Cluster Permitted = No
Cluster Active = No


Defaults :
========
Phy Polarity = 0
Phy PolaritySplit = 0
Strip Size = 64 KB
Write Policy = WB
Read Policy = Adaptive
Cache When BBU Bad = Off
Cached IO = Off
VD PowerSave Policy = Controller Defined
Default spin down time (mins) = 30
Coercion Mode = 128 MB
ZCR Config = Unknown
Max Chained Enclosures = 4
Direct PD Mapping = Yes
Restore Hot Spare on Insertion = No
Expose Enclosure Devices = No
Maintain PD Fail History = No
Zero Based Enclosure Enumeration = Yes
Disable Puncturing = No
EnableLDBBM = Yes
DisableHII = No
Un-Certified Hard Disk Drives = Allow
SMART Mode = Mode 6
Enable LED Header = No
LED Show Drive Activity = Yes
Dirty LED Shows Drive Activity = No
EnableCrashDump = No
Disable Online Controller Reset = No
Treat Single span R1E as R10 = Yes
Power Saving option = Enabled
TTY Log In Flash = Yes
Auto Enhanced Import = No
BreakMirror RAID Support = Yes
Disable Join Mirror = Yes
Enable Shield State = No
Time taken to detect CME = 60 sec


Capabilities :
============
Supported Drives = SAS, SATA
Boot Volume Supported = NO
RAID Level Supported = RAID0, RAID1, RAID5, RAID6, RAID00, RAID10, RAID50
, RAID60, PRL 11, PRL 11 with spanningPRL11-RLQ0 DDF layout with no span, PRL11-RLQ0 DDF layout with span
Enable JBOD = No
Mix in Enclosure = Allowed
Mix of SAS/SATA of HDD type in VD = Not Allowed
Mix of SAS/SATA of SSD type in VD = Not Allowed
Mix of SSD/HDD in VD = Not Allowed
SAS Disable = No
Max Arms Per VD = 32
Max Spans Per VD = 8
Max Arrays = 128
Max VD per array = 16
Max Number of VDs = 64
Max Parallel Commands = 1008
Max SGE Count = 60
Max Data Transfer Size = 8192 sectors
Max Strips PerIO = 42
Max Configurable CacheCade Size(GB) = 512
Max Transportable VDs = 0
Min Strip Size = 64 KB
Max Strip Size = 1.0 MB


Scheduled Tasks :
===============
Consistency Check Reoccurrence = 168 hrs
Next Consistency check launch = NA
Patrol Read Reoccurrence = 168 hrs
Next Patrol Read launch = 09/08/2018, 05:00:00
Battery learn Reoccurrence = 2160 hrs
OEMID = Dell

Drive Groups = 1

TOPOLOGY :
========

----------------------------------------------------------------------------
DG Arr Row EID:Slot DID Type  State BT      Size PDC  PI SED DS3  FSpace TR
----------------------------------------------------------------------------
 0 -   -   -        -   RAID6 Optl  N   1.635 TB dflt N  N   dflt N      N
 0 0   -   -        -   RAID6 Optl  N   1.635 TB dflt N  N   dflt N      N
 0 0   0   32:0     0   DRIVE Onln  N  837.75 GB dflt N  N   dflt -      N
 0 0   1   32:1     1   DRIVE Onln  N  837.75 GB dflt N  N   dflt -      N
 0 0   2   32:2     2   DRIVE Onln  N  837.75 GB dflt N  N   dflt -      N
 0 0   3   32:3     3   DRIVE Onln  N  837.75 GB dflt N  N   dflt -      N
----------------------------------------------------------------------------

DG=Disk Group Index|Arr=Array Index|Row=Row Index|EID=Enclosure Device ID
DID=Device ID|Type=Drive Type|Onln=Online|Rbld=Rebuild|Dgrd=Degraded
Pdgd=Partially degraded|Offln=Offline|BT=Background Task Active
PDC=PD Cache|PI=Protection Info|SED=Self Encrypting Drive|Frgn=Foreign
DS3=Dimmer Switch 3|dflt=Default|Msng=Missing|FSpace=Free Space Present
TR=Transport Ready

Virtual Drives = 1

VD LIST :
=======

-----------------------------------------------------------------------
DG/VD TYPE  State Access Consist Cache Cac sCC     Size Name
-----------------------------------------------------------------------
0/0   RAID6 Optl  RW     Yes     RWBD  -   OFF 1.635 TB Virtual Disk 0
-----------------------------------------------------------------------

Cac=CacheCade|Rec=Recovery|OfLn=OffLine|Pdgd=Partially Degraded|Dgrd=Degraded
Optl=Optimal|RO=Read Only|RW=Read Write|HD=Hidden|TRANS=TransportReady|B=Blocked|
Consist=Consistent|R=Read Ahead Always|NR=No Read Ahead|WB=WriteBack|
FWB=Force WriteBack|WT=WriteThrough|C=Cached IO|D=Direct IO|sCC=Scheduled
Check Consistency

Physical Drives = 8

PD LIST :
=======

------------------------------------------------------------------------
EID:Slt DID State DG      Size Intf Med SED PI SeSz Model            Sp
------------------------------------------------------------------------
32:0      0 Onln   0 837.75 GB SAS  HDD N   N  512B X423_HCOBE900A10 U
32:1      1 Onln   0 837.75 GB SAS  HDD N   N  512B X423_HCOBE900A10 U
32:2      2 Onln   0 837.75 GB SAS  HDD N   N  512B X423_HCOBE900A10 U
32:3      3 Onln   0 837.75 GB SAS  HDD N   N  512B X423_HCOBE900A10 U
32:4      4 UGood  - 837.75 GB SAS  HDD N   N  512B X423_HCOBE900A10 U
32:5      5 UGood  - 837.75 GB SAS  HDD N   N  512B X423_HCOBE900A10 U
32:6      6 UGood  - 837.75 GB SAS  HDD N   N  512B X423_HCOBE900A10 U
32:7      7 UGood  - 837.75 GB SAS  HDD N   N  512B X423_HCOBE900A10 U
------------------------------------------------------------------------

EID-Enclosure Device ID|Slt-Slot No.|DID-Device ID|DG-DriveGroup
DHS-Dedicated Hot Spare|UGood-Unconfigured Good|GHS-Global Hotspare
UBad-Unconfigured Bad|Onln-Online|Offln-Offline|Intf-Interface
Med-Media Type|SED-Self Encryptive Drive|PI-Protection Info
SeSz-Sector Size|Sp-Spun|U-Up|D-Down/PowerSave|T-Transition|F-Foreign
UGUnsp-Unsupported|UGShld-UnConfigured shielded|HSPShld-Hotspare shielded
CFShld-Configured shielded|Cpybck-CopyBack|CBShld-Copyback Shielded
0
timb551IT ManagerAuthor Commented:
A bit more information.

Now that i have windows installed the reconfigure option is available and i can increase the raid to include the additional 4 hard disks.

so that is now pointing to the fact that Centos is the issue which i find strange.  Any thoughts.
0
andyalderCommented:
Same as the thread you found I think, after all OMSA for VMware is the same as OMSA for Centos near enough except the VMware version has to be accessed remotely as no GUI.

Would be interesting if the CLI works under Centos.
0
timb551IT ManagerAuthor Commented:
I used the osm interface under windows to increase the raid size. Not sure how to increase using the cli. I will reinstall and have a test. Thanks
0
andyalderCommented:
It's a two step process using the CLI, first you use the perccli /cx/vx start migrate type-r6 option=add disk=x
then expand the array with perccli /cx/vx expand size=<value>

I've never done this on LSI/PERCs, used HPE's ACUCLI a few times but that's completely different. Easy to make a mistake and wreck your data but there's more available through the CLIs than through the GUIs.

If you want to play the CLI guide is at https://www.dell.com/support/manuals/uk/en/ukbsdt1/poweredge-rc-h830/perc10_plus_hba_clirg/virtual-drive-expansion-commands?guid=guid-fcb6a911-c863-481a-94cf-5f97531dbe47&lang=en-us
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
timb551IT ManagerAuthor Commented:
Things are looking good on Centos and using the PERCCLI

I have found the correct command and its currently running saying its got a further 7 hours to go.

Fingers crossed that all working but i will confirm back.

The command was perccli /cx/vx start migrate type=rx option=add drives=ex:sx,ex:sx,ex:sx,ex:sx

The Dell manual has it written down as disks= which is wrong and doesnt work.  They should really rewrite their manual.

Where x is you need to put the correct number in.
0
andyalderCommented:
Isn't it drives=ex:sx rather than ex,sx i.e. colons between enclosure and slot number?
0
timb551IT ManagerAuthor Commented:
yes sorry
0
timb551IT ManagerAuthor Commented:
Raid has finished reconfiguring and now all disks are included in the Raid6 setup.

Thanks for your help.  Got there in the end.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Dell

From novice to tech pro — start learning today.