Windows 10 - Hide Settings Page Visibility


I want to hide Windows update option under settings==>Update & Security for all Client computers in Our corporate network. This can be configured through GPO setting but it I suspect that it will apply only to computers regardless if it's an admin user or regular domain user Whos using the computer. I dont want to hide this option for admin users.

Another option is to configure this through registry at "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer" and create the string value "SettingsPagevisibility". The value must be configured as "hide:windowsupdate" (without quotes). The problem is that this registry setting is not being Applied and i've tried it several times, Google searched to verify if there is something i've missed but unfortunately it's not working.

My idea is to use a PS script where this setting will be created, then configure a GPO that runs this script at logon, delegate it to required secuirty group and link the GPO at required OU.

Hope I can get help on this

Kind regards
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Qlemo"Batchelor", Developer and EE Topic AdvisorCommented:
I don't know whether that works, but how about setting the registry value for HKCU instead of HKLM? Since it is user based, you can set up a GPO accordingly for some OUs or based on WMI results.
bhanu2000noAuthor Commented:
Hi Qlemo

I tried to configure the same setting under "HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer" but that doesnt help either. Unless there's another registry path in HKCU.

Anyways, thanks for the reply.
Qlemo"Batchelor", Developer and EE Topic AdvisorCommented:
You changed that value, and then logged out and in again?
bhanu2000noAuthor Commented:
Hi Qlemo

Sorry for my late reply. It didn't work even if the user is logges out and in again. However, I managed to find a solution. The acutal path is HKLM\software\Microsoft\Windows\CurrentVersion\POLICIES\Explorer". Creating a registry string value for hiding windows update here is now actually working.

The strange thing is that this setting only worked under HKLM and not HKCU. I simply created two GPO. One for ordinary domain users where the registry setting is creating when the users logon. The other for admin users, where the registry setting is deleted when admin users logon.

So now it's working as I wanted to.

Kind regards


Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows OS

From novice to tech pro — start learning today.