cannot sync from on-prem AD attributes: msExchExtensionCustomAttribute1-5 to Azure AD using Azure AD Connect

Newguy 123
Newguy 123 used Ask the Experts™
on
Hello Experts. I have Exchange 2013 CU21 with AD2012 R2 on prem. I also have Azure AD connect setup with Exchange hybrid to Office 365, and AD Connect server is syncing the required users and attributes to Azure AD. I am trying to sync the attributes from my on-prem AD: msExchExtensionCustomAttribute1-5 to Azure AD. However i am unsuccessfull in doing so. I see that my Azure AD Connect sync is picking up the new attributes, but it does not update them in Azure AD.
According to this microsoft kb: https://docs.microsoft.com/en-us/azure/active-directory/connect/active-directory-aadconnectsync-attributes-synchronized 
it mentions that these attributes are not consumes by Exchange online, but that means they should still be able to sync to Azure AD...which in my case they are not. Please let me know if anyone was successful syncing these attributes to their Azure AD from on-prem AD. Thanks in advance.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Most Valuable Expert 2015
Distinguished Expert 2018
Commented:
Well, how are you checking if they are being synchornized? Afaik those attributes are not exposed anywhere in O365, not even when using the Graph API directly. If you want to use them, you can just edit the sync rules to map them to a different attribute.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial