How to include desktop in roaming profile's folders

Alain Bensimon
Alain Bensimon used Ask the Experts™
on
I have roaming profiles in my organization.
I have realized that the desktop is not included in the synchronized folders.
how can I add it?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Distinguished Expert 2018

Commented:
That folder is included in a roaming profiles by default. If yours isn't, it points to an active change. Either by GPO, or folder permissions were edited in a way that the engine can't roam the folder. Or you are using a different technology or process.

Author

Commented:
I've never made any changes, and nobody before me had used roaming profiles. That is why I don't understand why they are not included. How could I check that and include it?
Distinguished Expert 2018

Commented:
There is a registry key that lists EXCLUDED folders. If desktop isn't listed then the engine will try to include it. You can find that key with a quick Google search.

Note that this *onky* applies to roaming profiles. 3rd party products, folder redirection, or work folders have different behaviors each. Roaming profiles is the oldest and least deployed (and is basically a dead technology) in that context.
Ensure you’re charging the right price for your IT

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Top Expert 2016

Commented:
The registry entry mentioned above is:
HKCU\Software\Microsoft\Windows NT\CurrentVersion\Winlogon. ExcludeProfileDirs.REG_SZ semicolon-deliminated-list

Author

Commented:
So I've checked that key, and here is its content:
AppData\Local;AppData\LocalLow;$Recycle.Bin
Top Expert 2016

Commented:
configure it in Users group policy preferences
Windows Settings\Registry\ExcludeProfileDirs
Distinguished Expert 2018

Commented:
Then desktop is not excluded. If it isn't roaming then you either aren't using roaming profiles (and are using something else that provides similar behavior) or roaming profiles is UNABLE to roam due to an error (which will be logged in the event log.)

Author

Commented:
here?
excludes.JPG
Distinguished Expert 2018

Commented:
That at first glance looks to be set by group policy (given the "policies" path) and will get reverted if it is.  Manually editing policies is usually not a good idea.

Author

Commented:
I do use it.I use this for all myb users in "profile".
\\cadc03\profiles\%USERNAME%and here are my profiles
Profilesand my folders, you see thet desktop is missing (I can see these folders because I've taken ownership of a person's profile taht does not work here anymore.
folders
Top Expert 2016

Commented:
yes desktop is being excluded!
HI, Alain.  Are you using traditional roaming profiles by setting the profile path in the user's Active Directory account?  If that's the case, then there has to be some other policy or registry change that's preventing redirection of the desktop folder, or possibly redirecting it somewhere else.  Did you check the folder redirection policies in group policy to see if someone had set up a separate redirection for the Desktop folder?  This could be in the Default Domain Policy (not the recommended way to do it but it's possible), or a separate group policy.

This policy is found at:

User Configuration/Policies/Windows Settings/Folder Redirection/Desktop

If there are policies set up that you didn't create yourself, you may want to use the Group Policy Results wizard to test a specific workstation.  This tool will identify all the policies that are being applied to a specific workstation. It's part of the Group Policy Management console.
Looks like someone (me) didn't see one of your posts.  The "ExcludeProfileDirs" registry value shown in your screen capture clearly shows that the Desktop folder is excluded from the roaming profile. You need to look for this setting in the group policies on your domain. You can use the Group Policy Results wizard mentioned in my previous post if you don't know what policy might have these settings. The setting is found at:

User Configuration/Policies/Administrative Templates/System/User Profiles/Exclude directories in roaming profile

Hope this helps!

Author

Commented:
Ok, so I've found the GPO that exclude it
global-gpo.JPG.
It's a main one with a bunch of rules, so I can't disable it.
Can I create another one that will re-enable it?
No need to create a separate policy.  You don't have to do anything other than remove the Desktop item from the policy setting.  The rest of the policy can stay in place as is.

IOW, you just open the group policy to edit it from the Group Policy Management Console list - just right-click on the policy and click Edit. Within the policy listing, navigate to the Exclude directories in roaming profile item and double-click to open it. Delete the Desktop folder from the list and then apply the change. Close the policy Editor window - DONE!

Author

Commented:
I understand, but this policy also applies to other countries of our organization, so if I delete that policy, it will apply worldwide and I only want to do it for us.
Top Expert 2016

Commented:
then create a new gpo in either sites or specific ou

Author

Commented:
Thank you all. I have been able to track the GPO that was doign that, and I've created a new one without "desktop" and I have enforced it. It works as expected.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial