Eclipse with Java

AXISHK
AXISHK used Ask the Experts™
on
Install WindowBuilder Plugin in Eclipse but it get the followings errors :

Eclipse is running 0, but this Java project has a 10 Java compliance level, so WindowBuilder will not able to load accesses from this project.

Any idea ? Does WindowBuilder support latest Java version ? Is it still support in future Java or I should use other gui tools ?

Thx
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Top Expert 2016

Commented:
You'd have to ask the plugin developers - we almost certainly are not they
Jeffrey Dake Senior Director of Technologyy

Commented:
My first guess is that you have your project setup to use Java 10, but it appears the plugin you are using does not support that version of java.  Doing some digging I think it will work if you drop down your project settings to use Java 9.

Author

Commented:
It works if I go back to JRE 8.

Should I use WindowBuilder as Java GUI development ? Has it already disconnected from Java future support ?

Thx.
Senior Director of Technologyy
Commented:
I can’t say I have ever used it. Looks like it is still being maintained though. https://projects.eclipse.org/projects/tools.windowbuilder/releases/1.9.2

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial