Options for all vms are greyed out in vcenter

We are running ESXi ENT PLUS 6 and for some reason when right clicking on any vm, the options are all greyed out.
We have done no updates or anything lately on any of the host.
Any ideas on what we can do to get these options back?
Also I am logged in as one of the administrators.
LVL 1
vmichAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Thomas UCommented:
HI vmich

you again? gosh ;-)

I had that multiple times (but not strangely not recently, they maybe fixed it). A reboot of the client on which you connect(sometimes only close the vmware client and reopen it) solves it.
If not, restart the vcenter services.

If that does not help, come back here, we will investigate further.

cheers
Thomas
0
vmichAuthor Commented:
Yep me again. You must not be busy today... :)
Ok Ill check it out and let you know.
0
Thomas UCommented:
yeah, I need some points to get free membership again, so here we are...no worry I just answer to things I experienced as well and had a solution to it ;-)

ps: where I live its 9PM
0
Newly released Acronis True Image 2019

In announcing the release of the 15th Anniversary Edition of Acronis True Image 2019, the company revealed that its artificial intelligence-based anti-ransomware technology – stopped more than 200,000 ransomware attacks on 150,000 customers last year.

vmichAuthor Commented:
Oh ok well its 3:25PM here..
Anyway I did the things you suggested before I posted this question. Reboot pc, close vcenter, etc.
Still same issue. When I right click now on any vm, all of the options are greyed out
0
Thomas UCommented:
Have you restarted the VCENTER Server? No worries, all the VM's will run just fine until vcenter server is back. If its an appliance, it will need a couple minutes to come back up.
If its installed on WIndows, it'll need 10-20 minutes to come back up.

Sometimes the most issues are with DNS not wokring properly. If ESXI cannot talk to its DNS provided, it will scream like a baby and do nothing until they are back in place.

No  options could also be a permissions issue, referring to the DNS thing above. is the vcenter domain joined? do you log on with the default user, like administrator@vsphere.local (if not changed) or an AD account?. Can you logon to a single vsphere esxi server with the root account?
0
Senior IT System EngineerIT ProfessionalCommented:
What about VM Snapshot or try with different browser?
0
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Task in Progress ?
0
Thomas UCommented:
Hmm. I highly assumed he tries to access with vmware vsphere client, because there it happens from time to time.

But yes, vmich, do you access via Browser? Do you use the flash oder the html5 interface as the guy who actually used "Senior IT System Engineer" as Name stated?
0
vmichAuthor Commented:
Well all thoughts are good but I have been using the same browser for quite sometime and logging in with the same admin account as always and now I found out that even another user that tries to login to the vsphere client is seeing the same thing and he has the admin rights also and always has.. So at this point none of this is making any sense why these options are greyed out.
I m going to try a  reboot of the vcenter now as Thomas suggested and see what happens.
0
vmichAuthor Commented:
Well I did a reboot of the vcenter but when trying to access the options of any vm via vspehere client, all is still greyed out.
I even connect to one of the host direct via vsphere client and the same thing is happening..
0
vmichAuthor Commented:
Ok more findings..
The options that are greyed out are when you right click on any vm, the guest options are they ones that are all greyed out. The power options are all available.
0
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Are these VMs on or off ?

Which Guest Options ?
0
Thomas UCommented:
Pleae check those two articles

https://kb.vmware.com/s/article/2048748
https://blogs.vmware.com/kb/2013/08/troubleshooting-when-virtual-machine-operations-are-greyed-out.html

Maybe there are other tasks running that locked all the VM's.
Are you logging in with a AD account or with the vcenter administrator?

regards
Thomas
0
vmichAuthor Commented:
All of the options under guest are greyed out.
Logging in with the same ad account which is an administrator account that we always use.
Thomas I will check the 2 links you just posted
0
Thomas UCommented:
Hi Vmich

Yeah but "the administrator you always use" maybe an AD Account, and hence the vcenter may not have contact to an AD server anymore, you will not have permission to alter anything.
Do you have another adminaccount that has a different domain?
0
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
if you get around, and login direct to ESXi, the root account should override, UNLESS the VM is in use!
0
vmichAuthor Commented:
This is very weird.
Did login into one of the host with root and the same thing the guest options are greyed out
0
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
on all VMs ?
0
Thomas UCommented:
in this case I think there is a TASk going on which locks all your VM's.
Let's say a backup that happend but stopped working for any reasons, your VM's are still locked.

Then you need to kill the task that hung up, as in the vmware article. Since you have it on ALL vm's that could maybe the case.
Is there not any errormessage or red in the tasklist? There must be anything stating that something is wrong.
0
vmichAuthor Commented:
So whether I login with the vsphere or login into a host with root, no matter which vm I right click on, the guest options are all greyed out..
I guess I have to try to see if there is something that is running that is causing this...
0
vmichAuthor Commented:
Sorry forgot to add that no there is no errors or red in the task list
0
Thomas UCommented:
That is in fact very strange...without haveing a look directly to the servers, I don't think I have any other Idea besides you check if any task is going on that locks the VM's, see vmware article.

Maybe someone else has another idea what it could be.
0
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
If you reset Network Management Agents, and vCenter Server service - reset.

Disconnect and/or remove ESXi host from vCenter Server.

Finally restarting hosts, should release all locks (unless shared storage)

Worth a check of logs as well
0
vmichAuthor Commented:
Ok I just found something out which I guess I did not or over looked...
When you connect to a vm in vsphere via the console, the options are now there but if you do it via vsphere and just select a vm on the left side, the option is greyed out. Which I found out is the normal operation
0
Thomas UCommented:
I don't understand..What do you mean by "connect to a vm in vsphere via the console" the vmware vsphere client that you can install on windows?

What do you mean by "..but if you do it via vpshere and just select a vm on the left side...:" You mean via Webinterface?

If only in webinterface, could it be a webbrowser/flash issue then?

regards
Thomas
0
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
what option are you wanting to change ?
0
vmichAuthor Commented:
No sorry for my poor post..
When going onto vsphere, select a vm and right click on it, the option for the guest is greyed out.
Now if you again select a vm and select open cosnsole, then  the guest options are there.
So I was thinking for some stupid reason that the guest options would also be available if you were not in a console for a vm...
0
Thomas UCommented:
I think I understand...now...lol..No issue then

 
grey1
grey2
thats normal behavior
0
vmichAuthor Commented:
Yes you got it..
I guess I wasn't thinking clear when I tried the options...
:(
0
vmichAuthor Commented:
NO ISSUE...
When going onto vsphere, select a vm and right click on it, the option for the guest is greyed out.
Now if you again select a vm and select open cosnsole, then  the guest options are there.

This is normal and by design...
Thanks to Thomas and Andrew for their input though since it was myself with  my unclear post and thoughts..
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Virtualization

From novice to tech pro — start learning today.