iMacros with C#

ybt
ybt used Ask the Experts™
on
I'm trying to use iMacros with C# in Visual Studio 2013
my code:

using iMacros;

...

{
           iMacros.AppClass imApp = new iMacros.AppClass(); // Object aanmaken van de namespace iMacros class AppClass
            iMacros.Status imStatus;
}

Open in new window


got an error:

interop type iMacros.AppClass cannot be embedded.

What could I do to resolve this?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
AndyAinscowFreelance programmer / Consultant

Commented:
Chinmay PatelChief Technology Ninja
Distinguished Expert 2018

Commented:
Hi ybt,

Try this:

           iMacros.App imApp = new iMacros.App();
            iMacros.Status imStatus;

Open in new window


Regards,
Chinmay.
ybt

Author

Commented:
iMacros.App imApp = new iMacros.App(); opens a new window outside of my application
Expert Spotlight: Joe Anderson (DatabaseMX)

We’ve posted a new Expert Spotlight!  Joe Anderson (DatabaseMX) has been on Experts Exchange since 2006. Learn more about this database architect, guitar aficionado, and Microsoft MVP.

AndyAinscowFreelance programmer / Consultant

Commented:
Have you followed my link and read it?
ybt

Author

Commented:
I followed that link, but there also recommended to switch to application instead of class .
and I took this example : iMacros.AppClass imApp = new iMacros.AppClass();
from this place:
https://pastebin.com/x21qaNZC
AndyAinscowFreelance programmer / Consultant

Commented:
OK.
So is your error corrected ?  (From what you say it seems to be so you are expected to choose all comments which helped and close the question).


got an error:

    interop type iMacros.AppClass cannot be embedded.
ybt

Author

Commented:
No, error was not corrected, I got this error when I copied a declaration to my environment, I assume that something wrong with my references or settings and this why I need help
Freelance programmer / Consultant
Commented:
So have you tried the other suggestion in the link I posted - change the setting Embed Interop Types to false - with your original code ?
ybt

Author

Commented:
Thank you, because I'm using VS2013 and recommendations were for VS2010 I had a problem to find where to change to false.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial