Rdp local resources not showing

Windows 2012r2. Rdp server

When I have a sub CD-ROM device attached to a client. And then crest rdp session to the server I’d like the cd rom to be available.  
But it’s not working
Client has all the right tick boxes ticked

I’m sure there is just a gpo setting somewhere but can’t find what’s preventing it from working.

Any ideas or log locations   ?


Although I’m pretty sure I’ve covered the basics.
LVL 1
Mike HammerAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Steven CarnahanNetwork ManagerCommented:
"Client has all the right tick boxes ticked"  

When you "tick" the box for drives there is a plus sign that you need to click to expand and select which drives.
0
Mike HammerAuthor Commented:
Yes everything is as it works on home setup

I just can't get it to work on a locked down server struggling to find what's preventing it
0
Steven CarnahanNetwork ManagerCommented:
Is it not available at all or can you see the drive but can't access any CD placed in the drive?  I don't have a CD drive available right now so can't test it.

There was another question asked here a few years ago that was forced accepted to close but may provide some further insight:

https://www.experts-exchange.com/questions/24201474/CDROM-access-in-Remote-Desktop.html
0
Acronis True Image 2019 just released!

Create a reliable backup. Make sure you always have dependable copies of your data so you can restore your entire system or individual files.

Mike HammerAuthor Commented:
Thank you I'll check it out

Nothing happens I don't see the drive (s) at all.  

It's not just cd also the local hard drives don't appear either.    
It's like the whole local resources thing is not working
0
Sajid Shaik MSr. System AdminCommented:
is this CD rom USB ?

if yes check GP

showing in the following article

https://www.experts-exchange.com/questions/24201474/CDROM-access-in-Remote-Desktop.html

Make sure that the following Group Policy setting is enabled: All Removable Storage: Allow direct access in remote sessions.
by Ankit_jain

all the best
0
Qlemo"Batchelor", Developer and EE Topic AdvisorCommented:
Assuming the client is in a domain and you cannot even see drives in the setup (while not connected via RDP) - did you check the applied GPOs with gpresult already? Should be pretty obvious if there are such settings.

AFAIK RDP GPOs are only appliable on the server side. You can also use tsconfig.msc to switch off drive redirection, again on the server side. Both just leads to the server ignoring your RDP file settings for drive redirection.
0
Mike HammerAuthor Commented:
Cheers. Rsop lol fine. I did do a gpo with the settings mentioned in this thread and a few googled ones. Even if I put in a new ou with no other gpos.
0
Qlemo"Batchelor", Developer and EE Topic AdvisorCommented:
I didn't understand your last post. Does "Rsop lol fine" mean that RSOP does not show any related policy?

Please confirm: You can set up local drive sharing fine in MSTSC, but it just doesn't happen to do anything while connected to the server?
Then you need to do some difference analysis. Try the same with another "server" machine (can be client OS). If it doesn't work there to, a GPO setting  is (still) most likely. In any case I would check the tsconfig.msc on the server.
0
Mike HammerAuthor Commented:
Rsop shows
The policy settlings mentioned in this post as applied

I'm not at work today but will check the mstsc settings tomorrow. Thank you.  

This works fine at home in s test rig. Same Os
So I know how to do it in principle.  Just struggling to trouble shoot the issue at work

Cheers
0
Qlemo"Batchelor", Developer and EE Topic AdvisorCommented:
You need to be more precise. "Applied" doesn't mean "set", only that some value is set (versus "unknown"). We need to see the exaxct setting.

Are you saying that one client doesn't work, whether your other one does?
0
Mike HammerAuthor Commented:
No.  I'm saying.  In one environment    It works.  In a separate environment it doesn't.

I'm not at work so can't be exact just now.   But. When I say applied I mean the correct setting is set,  I know what's supposed to be set.   It's not working. So loooking for reasons
0
Mike HammerAuthor Commented:
No tsconfig on 2012r2
0
Mike HammerAuthor Commented:
Fixed.  I'll post solution tomorrow. Away from work at present thanks for contributing
0
Mike HammerAuthor Commented:
This set of changes worked.  (We use usb drives too)
There may be some unneeded but no time to test this week
Computer configuration
System/removable storage access
All removable storage. Allow direct access in remote sessions.    Enabled

Windows/components/Remote Desktop services/Remote Desktop session host /device and resource redirection
Do not allow com port redirection.   Disabled
Do not allow drive redirection.  Disabled
Do not allow supported plug and play device redirection.   Disabled


Also did. Allow rdp redirection of other supported remote fx usb devices from this computer enabled.  But works with out that too
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Mike HammerAuthor Commented:
Try this
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Remote Access

From novice to tech pro — start learning today.