We help IT Professionals succeed at work.

exchange calendar invitation broken to external exchange/office 365 servers

Robert Mulvey
on
136 Views
Last Modified: 2018-09-13
exchange calendar invitation broken to external exchange/office 365 servers
When we send exchange calendar invitations it is broken to other exchange/office 365 servers but it appears to be ok when sent to linux servers

below is an example of a broken calendar invite when it is received.   The receiver cannot accept nor does it show up on their calendar, they only get a plain text email.  It also appears if we accept an external invitation but the acceptance is broken going back to them, it shows as not accepted/no status.    All other emails appear to be ok in terms of richtext/html and people receiving our attachments.  We have Exchange 2010/2016.  This issues has existed before 2016 was introduced.  The outgoing email is smart hosted thru our Cisco ESA Appliance aka IronPort.
example of broken invitation.
Comment
Watch Question

Saif ShaikhServer engineer
CERTIFIED EXPERT

Commented:
Try to check the outlook Options > Mail, section Message format:

On exchange server Get-RemoteDomain | Where {$_.TNEFEnabled -ne $false}

For each Remote domain, run the following command:
Set-RemoteDomain -Identity DomainName -TNEFEnabled $false

On exchange 2010 run command: Get-RemoteDomain | fl

The ContentType should be set either to MimeHtml

For domains that have the default content type set to MimeText, you need to change the ContentType property via the cmdlet below:
Set-RemoteDomain -Identity <name> -ContentType <type>
Saif ShaikhServer engineer
CERTIFIED EXPERT

Commented:
Hello,

To add to my earlier update since you have IRONPORT.

A normal meeting request content type should be “Content-Type: multipart/alternative;” while a plain text meeting request content type is showing “Content-Type: multipart/mixed; boundary=”===============0763446457==

1. As stated earlier TNEF value needs to set to false .
2. Try to create a new outbound connector and route the email traffic through it, so that the emails go directly with this connector and disable the gateway connector. Send a test calendar invite and it should be received normally as calendar.
3. Further troubleshooting adds Gateway must be modifying the message header type in order to show up the Disclaimer of the email correctly.
4. You need to correct the Gateway in Ironport I mean settings.
5. Also since you are using smarthost, it is possible that the smarthost considers these emails as spam and converts them to plain txt, but I'm not sure about this may be you can check with smarthost vendor and see if they have some kind of rule for these types of messages.
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION

Gain unlimited access to on-demand training courses with an Experts Exchange subscription.

Get Access
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Empower Your Career
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE

Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.