Link to home
Create AccountLog in
Avatar of vibinsathyan
vibinsathyan

asked on

Exchange server 2016 Autodiscover not working

I created a test exchange server 2016 (internal only) but Autodiscover is not working.
I tried troubleshooting but was unsuccessful.
please advice.
Avatar of Saif Shaikh
Saif Shaikh
Flag of India image

Did you installed SSL certificate on exchange server or are you using auto-discover internally?
Do post the error which you are getting.

Are you trying to configure outlook 2016 or running some test like test-exchangewebservices?
Avatar of vibinsathyan
vibinsathyan

ASKER

I Am trying to configure outlook.
I can manually configure with IMAP/POP3 but autodiscover is not working.
Connection is being established but it hangs on searching for email@domain.com
Will show error to retry with unencrypted setings but will not succeed.
I am trying internally only - not installed any certificate.
Outlook 2016 connects using autodiscover so you need to purchase an SSL certificate with autodiscover SAN name in it and a host A record needs to be added in public DNS.
But I need only to connect internally..It is not working through public DNS..
I tried with Outlook 2013 and it is working fine.
Any workaround for Outlook 2016 for conencting autodiscover.
Check Out this Link, to find the solution :

1. Do I need to add the Autodiscover name to my SSL certificate?
2.  Do I need an Autodiscover name for all of my SMTP domains in my SSL certificate?

https://webcache.googleusercontent.com/search?q=cache:ap2EVfE731UJ:https://practical365.com/exchange-server/exchange-2010-faq-autodiscover-names-ssl-certificate/+&cd=1&hl=en&ct=clnk&gl=us
Outlook 2016 is also working fine now but only making default DNS server to Exchange domain DNS (In my case same Exchange Server).
I tried putting A, CNAME , MX and SRV record for the exchange server but not working.
Actually setup is working fine but after outlook restart it will show error as folders cannot be updated.
I tried deleting all records other than srv but not resolved the issue.
Exchange autodiscovering is working and adding the account but after that it will ask for restart outlook.
But then it will show error for ost as folders cannot be updated.
ASKER CERTIFIED SOLUTION
Avatar of vibinsathyan
vibinsathyan

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
No comment has been added to this question in more than 21 days, so it is now classified as abandoned.

I have recommended this question be closed as follows:

Accept: 'vibinsathyan' (https:#a42694465)

If you feel this question should be closed differently, post an objection and the moderators will review all objections and close it as they feel fit. If no one objects, this question will be closed automatically the way described above.

seth2740
Experts-Exchange Cleanup Volunteer