A Remote Desktop Services Deployment does not exist in the server pool.

I have a Server 2012 R2 Guest Machine, A Domain Controller that is a guest as well. It is a production environment and has been running well since 2012. Recently we received a new public IP address and had to make some adjustments to the server:

New SSL cert applied after the change.
Made sure no IPv6 is running. with the new router/switch.

Everything is working. httsp://access.somedumbdomain.com/rdweb works, all offices can connect. 5 off site locations can connect.

A vendor needs to update his software for the client, we login and to manage rdweb services though the server manager and we discover the A remote desktop services deployment does not exist in the server pool.

I have googled every error in the error logs, tried ever thing in for the words A remote desktop services deployment does not exist in the server pool.

Help!
Member_2_6452845Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Cliff GaliherCommented:
That almost always meana that the server with the connection broker role has not been added to server manager.

Keep in mind that Server Manager can manage remote machines as well as the local machine it is installed on. Especially for RDS, thus is important as it WON'T add remote RDS servers to its interface on its own. So if you don't add the RDCB so it knows about it, that error pops.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Member_2_6452845Author Commented:
It is and has been.... I did have to remove it from the domain and rejoin should I remove it from the server manager and add it back?
0
matrix8086Commented:
On the host where RDWeb role is installed, check the settings for the rdweb. I suppose that RDweb points to the old public IP, or something like that
0
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

Cliff GaliherCommented:
Yes, you will probably have to remove and re-add it to server manager. AD creates a new account when you remove and rejoin. Even if the machine has the same name. Internally server manager doesn't know that it needs to connect to a new computer account.
0
Member_2_6452845Author Commented:
The server only provides the service on the local ip, not a public. The fire wall directs all rdweb to be answered by the interior ip and we put in a new firewall so lingering bad public ip address.
0
Member_2_6452845Author Commented:
The domain controller has the access server on its all server list, and the access has the domain controller on its all server lists. Is this an improper configuration. I have removed them both and will now commit a restart.
0
Cliff GaliherCommented:
If by  list" you mean in server manager that is per user profile. It isn't a configuration that persists when a user isn't logged in. While I'd wonder why an admin is logging into each machine and running server manager instead of using an admin station, I wouldn't call it "wrong." It just highlights some other security concerns against usage best practices that should be cleaned up.
0
Member_2_6452845Author Commented:
Sooo... you lead me to a place to fix it. I removed and re-added the access server to the server manager in the domain I get a warning that says please verify winRM is running. Few strokes later I am at the following command: winrm quickconfig and boom done and I can get to collections.
Thanks.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Remote Access

From novice to tech pro — start learning today.