Certificate status shown as invalid

Hi All

Please note we have an exchange 2010 server that is running fine with out any issues. We have just introduced an exchange 2013  server. We have bought a SAN from godaddy and applied it to new server exchange 2013. I have added the certificate to Certificates in personal, trusted root certification Authority as well as intermediate certification authorities

When i go to EAC the certificate is there but status says invalid. Any suggestions?

I have already tried
https://danblee.com/a-special-rpc-error-occurred-cannot-import-certificate-a-certificate-with-the-thumbprint-already-exists/

https://support.microsoft.com/en-us/help/954755/how-to-configure-intermediate-certificates-on-a-computer-that-is-runni
Member_2_6474242Senior Systems AdministratorAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

timgreen7077Exchange EngineerCommented:
use the below link from Godaddy to help you properly install the Godaddy SSL cert.

https://www.godaddy.com/help/exchange-server-2013-install-a-certificate-4774

also you should only have 1 SSL cert there is no need for 2, so you can either export and import the 2010 cert to 2013 or you can export and import the cert you got for 2013  into 2010.
1
Michael B. SmithExchange & Active Directory ExpertCommented:
The cert (and intermediates) should go to Local Machine, not to Current User.
1
Member_2_6474242Senior Systems AdministratorAuthor Commented:
Hi Timegreen7077

I have tried the same settings but i still get the same error
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

Member_2_6474242Senior Systems AdministratorAuthor Commented:
Hi Michael

All certificates are in local Machine
0
Glen KnightCommented:
Have you actually created a certificate request within Exchange and then imported the resultant certificate from GoDaddy?
0
Michael B. SmithExchange & Active Directory ExpertCommented:
i'd like to see a screenshot of the invalid certificate and of the certificate chain.
0
Member_2_6474242Senior Systems AdministratorAuthor Commented:
HI All

I managed to fix this with DigiCertUtil. I had to disable seetings

What i did
1. open DigiCertUtil
2. Go to Tools-->Windows automatic root update
3. Click on Autoroot update
4. Select disable and click ok
0
Member_2_6474242Senior Systems AdministratorAuthor Commented:
Thanks to all.  Solution as per above
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.