We help IT Professionals succeed at work.

Owner incorrectly set on roaming profile creation

152 Views
Last Modified: 2018-09-17
User profile created by default owner is set to server\administrator instead of that user.  Folder redirection 502 (access denied) as a result.

Any suggestions?

Thanks in advanced.
Comment
Watch Question

CERTIFIED EXPERT
Distinguished Expert 2019

Commented:
check GPO for roaming profile, check the share permissions and security permission dealing with who can write into the profile share.

Usually domain users should have full rights on the share side
and on the security side

When the roaming profile is copied out it sets the user as the owner and only the user has access unless you use a ROAMING Profile setting GPO that adds administrators to the profile ...

If you are using the user profile folder, \\server\users$\%username% as the home directory, this is why domain\administrator is the owners, as you create this folder when the account is created/added.


create a new test account, do not set home dir....
and see if it behaves the same way.
Kyle AbrahamsSenior .Net Developer
CERTIFIED EXPERT

Author

Commented:
GPO for Roaming profile:  Currently I don't have one set.  I've taken that out to simplify things for now.

New setup after changing the settings:  (EG: From my first to 2nd question):

profilepath:  \\server\userprofiles$\<user>
HomeFolder: \\server\users$\<user>

If I don't set the homefolder the directory doesn't get created and folder redirection breaks.

Is it better to specify this in GPO and if so where do I find that settings?  Sorry for my lack of knowledge here but I'm a programmer putting on a domain admin hat for a small company.
CERTIFIED EXPERT
Distinguished Expert 2019
Commented:
This problem has been solved!
(Unlock this solution with a 7-day Free Trial)
UNLOCK SOLUTION
Kyle AbrahamsSenior .Net Developer
CERTIFIED EXPERT

Author

Commented:
Currently all the servers are VMs hosted on an SAN array (HP MSA 1050).  I don't believe we need DFS in that case from what I'm seeing - or would you still recommend it?  Out of work for the weekend, will try these settings on Monday.

Thanks again for the help.
CERTIFIED EXPERT
Distinguished Expert 2019

Commented:
VM's also go bad.
so in the event you can not roll back a snapshot....... without losing data
the DFS-R/DFS  provides for a seamless transition since within DFS
\\domain\userprofile you can change the target without the user seeing any impact.
i.e. \\domain\userprofile -> server1\userprofile
You setup a new VM running server2016
using DFS-R you can setup a replication group that will copy the data from server1
You can then add this new VM as a target .
You then change the reference to prefer the new VM
allowing time after confirming no people are accessing server1, you can remove its target reference.....

using two as long as either is up, the user has access to their data.
IN server based, if the server is being rebooted, updated, etc. the user experiences issues accessing their files/data.

The cost is in storage as it is duplicated (exists on each VM)
Kyle AbrahamsSenior .Net Developer
CERTIFIED EXPERT

Author

Commented:
Thanks.  Setting the GPO under Computer -> Admin Templates -> System -> User Profiles worked.

Set the set user home folder to my drive with
\\server\users$\%username%

set the roaming profile path for all users to
\\server\userprofiles$\%username

Created a new user without any additional settings and logged into a machine.
Immediately the directories were created in their appropriate places as well as they were set to owner properly.