Avatar of dedri
dedri
Flag for United States of America asked on

winscp to linux with admin privileges

I have several linux systems. Normally I login on them with my account, and after I login i execute sudo -s, so I can get admin privileges.
Sometimes I need to edit some files or copy some files out of the linux systems and in the past I ofter used the winscp program.
Unfortunately when I login with winscp with my account I don't have admin privileges, and thus I am not able to open and edit needed files, I am not able to copy files out of the system. Can you tell me how to login with winscp with admin privileges
LinuxLinux SecuritySSH / Telnet Software

Avatar of undefined
Last Comment
dedri

8/22/2022 - Mon
Scott Silva

You would need to login with an account that has root privileges. I don't think WINSCP has any form of sudo support. Or you would need to login via SSH and use the elevated command prompt to copy the files you need in and out of your home folder, then use winscp to get them from there...
noci

You would need to use SCP protocol with a ssh-certifcate and ONLY allow root to logon with the right certificate.
and have each user use their OWN certificate to still keep the tracking of who dit what, when..
ASKER CERTIFIED SOLUTION
Rahul Shende

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
dedri

ASKER
I tried as it is suggested in the article above, choose the SCP protocol , and in shell settings put sudo su-, and I receive the error message: error skipping startup message. Your shell is probably incompativle with the application(BASH is recommended)
 I also tried with the sudo -s and the same message appear
This is the best money I have ever spent. I cannot not tell you how many times these folks have saved my bacon. I learn so much from the contributors.
rwheeler23
dedri

ASKER
i downloaded new version of winscp and now it's working. Thank you Rahul.