Conencted to VPN cant access shares

Chris Walter
Chris Walter used Ask the Experts™
on
Using Microsoft VPN server\client on Server 2012. The 2012 server is in the cloud, I have set up the VPN server and I'm able to connect to the VPN, I can ping the VPN server, I can RDP to the server when connected to the VPN but I can not access a share on the server. This is a single server (non-domain) solution that remote clients need to access a database on this server. Port 139 is open, The VPN clients get an IP address on the same subnet as the server. when trying to access the share via IP \\999.999.99.99\share  I get Windows cannot access never prompts for user id. I have checked share and NTFS rights and the VPN users should have access. I get same results on Win10 VPN client and Win 7 VPN client
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Martyn SpencerSoftware Developer / Linux System Administrator / Managing Director

Commented:
If you open port 445, you may be able to connect using the server IP address. Try that. Also open ports 137-139 if you want to access the share by name since they are used for NETBIOS name resolution.

Note that this is what I have used in the past: 137/UDP, 138/UDP, 139/TCP and 445/TCP
Chris WalterPrincipal Owner at Castle Computing

Author

Commented:
its not a port issue, she is connecting fine and can access a share without security on it. Also I can connect from my office as her with not issues
Martyn SpencerSoftware Developer / Linux System Administrator / Managing Director

Commented:
she is connecting fine and can access a share without security on it
It would have helped if you had provided that information in the original question.

In this situation, I would use a network monitor to examine what is happening client-side and server side. It would appear to be an authentication or trust issue. There are probably some other Windows experts here who can offer more directed advice.
Principal Owner at Castle Computing
Commented:
Turned off Windows firewall on the RAS connection only
Martyn SpencerSoftware Developer / Linux System Administrator / Managing Director

Commented:
If turning off the firewall worked, then it is going to be a port issue. It's generally better to determine what the ports are in question rather than effectively leaving all ports open. But, at least you have it working now.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial