Need help disabling screen saver

pcalabria
pcalabria used Ask the Experts™
on
Can someone help me disable my screen savers?

I have a network of WinXP computers.  A screen saver automatically starts when the machine is not active.  The screen is black and the Windows logo movers around the screen.

I am connected to a domain and all machines which use the same group policy object exhibit this behavior.
I set up group policies years ago but don't remember what I did.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
JohnBusiness Consultant (Owner)
Most Valuable Expert 2012
Expert of the Year 2018

Commented:
What server operating system?  XP is dead and not serviceable.

Go to an XP machine and see if you can start a local Screen Saver and then use that.
Bagaudin SatuevGlobal Community Evangelist

Commented:
It must be in Control Panel\Display.

This .xls file contains all GPO settings for Windows XP, providing it for reference - www-pc.uni-regensburg.de/systemsw/winxp/info/winxpgpset.xls

Author

Commented:
XP is not dead... it's working fine on all 20 or our Robots.  And it will probably continue working fine as long as we don't connect the Robots to the internet.

The problem is that the screen saver starts automatically.  We do not want it to ever start.

I suspect it's a group policy installed on the server.
Why Diversity in Tech Matters

Kesha Williams, certified professional and software developer, explores the imbalance of diversity in the world of technology -- especially when it comes to hiring women. She showcases ways she's making a difference through the Colors of STEM program.

JohnBusiness Consultant (Owner)
Most Valuable Expert 2012
Expert of the Year 2018

Commented:
XP IS dead, gone, rotted in the grave. No updates. It is a serious security concern and should be dumped right away.
JohnBusiness Consultant (Owner)
Most Valuable Expert 2012
Expert of the Year 2018

Commented:
You can / should try local screen savers as we have suggested. No modern server OS GPO will adapt to XP. Are you still using Server 2003?  Please say NO to that one.

Commented:
Click on the 'Start' button then 'Control panel'

- Double click the 'Display' icon to open up the 'Display Properties' screen

- Click on the 'Screen Saver' tab

- Change the 'Screen saver' drop down box to '(None)' and then click on the 'Apply' button.

all the best

Author

Commented:
Yes. The robots connect to win 2003 server.  They run 24/7 with no problems, except that the screen saver starts automatically.  

I want to know how to configure GPO to disable the screen saver.

Commented:
at server gp level

Summary
You can make screen saver password locks unavailable on systems in a site, domain, or organizational unit, by using the policies available in Windows 2000.

Disable Screen Saver Passwords
To make screen saver password locks unavailable, follow these steps:

Click Start, and then click Run.
Type mmc, and then click OK to start the Microsoft Management Console (MMC).
On the Console menu, click Add/Remove Snap-ins, and then click Add.
Click Group Policy, and then click Add.

The Select Group Policy Object dialog box appears. If you want to apply this policy only to your computer, make sure that your local computer is listed in the Group Policy object, and then click Finish.

Alternatively, if this will be an Active Directory policy, click Browse, select the site, domain, or organizational unit to which you want this policy to apply, and then click Finish.
Click Close.
Expand User Configuration, and then expand Administrative Templates.
Expand Control Panel, and then click Display.
In the right pane, double-click Password protect the screen saver.
Click to select Disable on the Policy tab. This prevents users from setting passwords on screen savers for this computer or domain.
Click the Explain tab for information about how to use this policy.
Click Apply.
Click OK, and then close the MMC.


at pc level  by regedit
1. Go to Start - Run
2. Enter regedit and OK
3. In Windows Registry editor navigate to
[HKEY_USERS\.DEFAULT\Control Panel\Desktop]
4. Search for "ScreenSaveActive" data key
5. Change the value to 0


all the best

Author

Commented:
@Sajid  I want to prevent the screen saver from starting.  We are not using Passwords and I don' want to use passwords.

@Owen  I'm lost.  I'll keep looking at the article but its not making sense.


NOTE:  I know that at one point I enabled a specific screen saver in Group Policies... I suspect this policy is propagating down to the new user.  I can't seem to find where the original policy was specified, or how to block inheritance.
Commented:
Yea, I was afraid of that. It does warn it is a complicated task.

Can I ask how many machines this is for?

As old school as this may sound, maybe just going to each machine and making the change is the simplest and quickest answer.  On XP, right click on desktop, click properties, and choose the Screen Saver tab.  Or are these machines too far away?

So the solution in that article that seems to make most sense is making a Group Policy Object (a Group Policy Object (GPO) is a collection of settings that define what a system will look like and how it will behave for a defined group of users.) They talk about making a screen saver for the corporate, but you could give it any screen saver settings you want, including off. The answer by Martin, about 4 down is the one I would look at first.

Author

Commented:
We use group policies to lock down the machines, which are actually robots.  Users  do not have access to system files or any part of the local hard drive as you would a normal computer.

Basically, we boot the machine and it starts at a menu with limited options.

The problem is that the screen saver launches.. preventing us from seeing what's on the screen.

The computers can also be used as normal machines.. although heavily locked down.. simply by logging in with the users profile.


When you log in with the robots profile we want GP to give all of  he robots the same look.. ie wallpaper..etc


So I can't log into the local machine as a robot because right clicking the desktop gives an operation restricted message.

Commented:
Ah, sorry, I did not get that.

And you can't disable the screen saver in those group policies, right?

Author

Commented:
That's the problem.  The screen saver is disabled in group policies.. but it's still starting.


Admintemplates>control panel>display>screensaver disabled

Commented:
Im stuck, as I have no idea why. UNLESS, it is a different policy that is active during that particular screen.  I am just not sure how to find out.

Author

Commented:
Any other ideas?  I have noticed that the screen saver does NOT start when ABI, one of my users, who is in the same OI, logs in.  In fact, ABI does not seem to be getting the group policies linked to the OI... for example, ABI has different wallpaper from every other user in the OI.

This makes me wonder whether the Group Policies simply are not working properly for the other users???

Any help would be appreciated.  Thanks

Commented:
That is possible but I’m sorry, I don’t know the process for checking for failure. It has to be in the system log files I’m sure. Is ABI listed as a member of the group?

I did have a silly idea: a mouse mover to keep the screensaver from starting. REALLY old school idea, but I’m out of ideas here: https://mousetender.com/products/mouse-tender-2-0-motion-simulator-disk-only

Author

Commented:
Yes. ABI is in exactly the same OU as the other users.. and it is not getting the same policies..

Is there a way to reset policies.. something like you do with security in the Advanced tab... reset child objects.

Author

Commented:
Thank you, it was a Group Policy issue.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial