Exchange Server 2010 to 2016 mailflow problem

I installed a new Exchange Server 2016 in an existing Exchange Server 2010 environment.  I am now having trouble to send/receive mails between the Exchange Servers.  There is no Firewall between the both Servers, they are in the same LAN.

I am going nuts, do you have any idea why the mailflow does not work?
2010connector.jpg
whenzAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

MAS (MVE)EE Solution Guide - Technical Dept HeadCommented:
HI whenz,
Please make sure Exchange server authentication is enabled
test.JPGAnd make sure your internal FQDN is set properly.
test.JPGGet-clientAccessServer | fl Name,AutoDiscoverServiceInternalUri
Get-OabVirtualDirectory |  fl Server,Name,internalurl,externalurl
Get-WebServicesVirtualDirectory | fl Server,Identity,internalurl,externalurl
Get-EcpVirtualDirectory |  | fl Server,Identity,internalurl,externalurl
Get-OwaVirtualDirectory | fl Server,Identity,internalurl,externalurl
Get-ActiveSyncVirtualDirectory | fl Server,Identity,internalurl,externalurl
Keep External URLs null in Exchange 2010 and Set the IIS authentication to BASIC + NTLM in Exchange 2010. This is for OutlookAnywhere
Read this for more details.
https://social.technet.microsoft.com/wiki/contents/articles/31708.configure-exchange-2016-with-exchange-2010-coexistence.aspx

Use this URL to set URLs
https://www.experts-exchange.com/articles/31221/Fix-for-Exchange-server-2016-certificate-and-related-issues.html
https://www.experts-exchange.com/articles/29657/Exchange-2010-Fix-for-an-Invalid-certificate-and-related-issues.html
Please restart Transport service after the change.
0
Hani M .S. Al-habshiContributor as IT ExpertCommented:
Go to Server Configuration >> Hub Transport >>Default Receive connector >> Properties >>Authentication

 Enabled   Exchange server authentication


Go to Server Configuration >> Hub Transport >>Default Receive connector >> Properties >>General
FQDN  should be the host bios name example: (Local_Server_Name .domain.com)
0
whenzAuthor Commented:
Thank you for the hint.  I checked these settings, and everything seems to be correct.  I have the following scenario:


 - I send an email form external to a mailbox (lets call this mailbox Adrian) which is hosted on the exchange 2016 server
 - Adrian's mailbox has a mail forward to another external mail address, let's say thomas@gmail.com
 - When sending an email from an external address to Adrian, this mail does not arrive in the Mailbox of Adrian BUT it gets forwarded to thomas@gmail.com
 
any other idea how to proceed?

thanks!!
0
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

Arjun VyavahareTechnical ConsultantCommented:
Hi,

1. On the server you are trying to send TO, check the properties of the Default receive connector and ensure ‘Exchange Server authentication’ is selected.

Exchange Server Authentication

2. On the server you are trying to send TO, If you have a connector configured to ‘relay’ mail, make sure that the server(s) or network specified DOES NOT include the IP address of the server you cannot send FROM. Also Make sure on the authentication tab ‘Exchange Server authentication’ is NOT selected.

Relay Mail Connector

Cheers,
Arjun
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Hani M .S. Al-habshiContributor as IT ExpertCommented:
this mail does not arrive from external

1-You should recheck Split DNS Records ,A record , ,MX record,Static IP DNS Revers Name..etc  (use http://mxtoolbox.com )
 

2-Recheck your Receive Connectors .

3-Use https://testconnectivity.microsoft.com  and give us the report
0
whenzAuthor Commented:
Thanks Ajun, it was indeed a relay receive connector where the exchange server was in the ip range.  i removed that ip range and now it works. you are my hero!!!!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.