PhoneGap CLI install issue (Windows)

hindersaliva
hindersaliva used Ask the Experts™
on
I'm trying to install PhoneGap CLI. When I run this
npm install -g phonegap@latest

Open in new window


I get this
phonegap CLI install error
I have reinstalled Node.js
The versions I have are
Node 10.11.0
npm 5.4.2 (installed when installing Node, I believe)

Can anybody help please?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
HelpDesk Technician
Distinguished Expert 2018
Commented:
Hi hindersaliva,

You may not need to reinstall Node, just npm itself. You can uninstall and get the latest version of npm with these commands.

npm uninstall -g npm

npm i -g npm@next

Let us know if this works,
Martin Nguyen

Author

Commented:
Thanks Martin. That worked!

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial