Menu Hotkeys Stopped Working in VFP Environment

Within my VFP environment - and ONLY within my VFP environment -  I appear to have lost the abiility to use menu hotkeys.

For example, the ALT key still wakes up the UI menu, but I can't activate the Tools menu by pressing "T". If I cursor along to it or click it, I can see all the hotkeys underlined as usual, but none work. eg, if type "b" to open the debugger, nothing happens. I can only open it by cursoring to it or clicking on it.

That's weird enough but here are the complications/clues.

First, I'm getting the same behaviour on my two main development workstations. But not my laptop.

I get the same behaviour with vfp programs I've compiled on those machines; but ONLY if I run them on those machines. My clients running the same software on their workstations have no problem accessing the menus in the normal way.

Clearly its some kind of environment issue and clearly whatever I've done on one of the workstations, I've repeated on the other, but not on the laptop.  I should add that I've only had this problem since some time earlier this year. (Didn't note the date as I assumed it was a transient fault and would disappear with the next reboot or whatever. Then it just became a background irritant). I should also mention that the two workstations are running on different W10 versions (1511 and 1709, both 64 bit)

I do tweak windows quite radically (using Winaerotweaker and other tools for example) but I tend to be pretty consistent and can't imagine what I could have done on the two workstations but not the laptop. Nor can I imagine a windows tweak which would ONLY affect the VFP environment. (menus in all the other apps and browsers continue to work normally)

Thought it might have something to do with the vfp config files typically stored in the folder C:\Users\(username)\AppData\Roaming\Microsoft\Visual FoxPro 9, so I tried copying the files from that folder on the laptop to the equivalent folder on one of the workstations. Had no effect on the hotkey behaviour at all.

I am now officially stumped.

Suggestions?
Mike JacobsAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

pcelbaCommented:
"I do tweak windows quite radically" … this could be the main reason for VFP problems.

There are no VFP configs which could affect the menu behavior this way. You may do a small test - copy VFP files to a separate folder on some drive and try to execute VFP9 from this folder. You will need just a few files:

VFP9.EXE, VFP9ENU.DLL from C:\Program Files (x86)\Microsoft Visual FoxPro 9
MSVCR71.DLL, GDIPLUS.DLL from C:\Windows\SysWOW64\ or from elsewhere you find these files

and also place CONFIG.FPW containing two following lines to this folder:
resource = off
tmpfiles = <d:\path>  && this should point to the same folder where you copied the VFP9.EXE

VFP also has settings in Windows registry but they should not affect hotkeys (you may find them under Tools/Options).

Now you may execute VFP9.EXE and check hotkeys. I would guess the problem is still there. So you may continue with your Windows environment investigations. This means suspicious program uninstallation or even the workstation reinstallation.

BTW, what is your VFP9 build number?
0
Mike JacobsAuthor Commented:
Greeting pcelba

good test and your guess was correct. The problem is visible in the test folder as well.

re "suspicious" programs, I'm sufficiently paranoid to be reasonably confident that it is unlikely to be that. More likely to be a program I trust which, for some reason I haven't yet twigged, is having this undesirable effect. In part this "confidence" arises from the fact that my two main workstations are so different. My main one is at home (I work from home about 60% of the time) and the other is at my main client site. The client site version, in particular, runs pretty lean. So the only commonalities between the two are my trusted tools and utilities, which I've been using for a lot longer than this problem has existed. So I think it has to be something I've done for some utterly unconnected reason.  The bit that confuses me is that I know I haven't done anything (consciously) to the VFP environment and yet the problem is only showing up in VFP

Given the number of possible causes I suspect you're also right in thinking only reimaging will fix it.  So I'll probably bring home my other workstation and do the dirty. Then I'll gradually rebuild the tool set and parameters, testing at each stage to see what tweak has the undesired effect.  I'll report the results back here in case some other victim finds the same thing happening to them.

>>BTW, what is your VFP9 build number?
Unless you're using build number as synonymous with "version", I don't know it or how to find it. My vfp version is 9.0.0.7423
0
pcelbaCommented:
Yes, the build number = the last four digits of the VFP version number.

VFP menu handling is "old fashioned" and it can be incompatible with some other software. I've asked the Czech VFP group for opinions. I cannot believe you are the only person having problems with VFP 9 menu.
0
Protecting & Securing Your Critical Data

Considering 93 percent of companies file for bankruptcy within 12 months of a disaster that blocked access to their data for 10 days or more, planning for the worst is just smart business. Learn how Acronis Backup integrates security at every stage

Mike JacobsAuthor Commented:
Well that's a novel one.

Rebuilt my client site machine and gradually reintroduced all my standard software. Everything hunky till I reached SpyShelter.

Their version 11 (and later) which came out in June, is the cause of the problem. Disable their keystroke encryption and the problem went away. I can also add vfp9.exe to their exclusion list and then re-enable keystroke encryption. I have notified them and requested a fix, or at least an explanation of why it only affected VFP; though I suspect they'll probably tell me that I've already done as much as they're interested in.

I'm happy to give you to the points, if only for helping me eliminate various options and forcing me to face the re-imaging option. But I need to mark this message as the "Solution" because it's obviously the real cause. How do we arrange that?
1
pcelbaCommented:
It was my pleasure to help here and your final solution should be the only one selected as the answer.
I've learned something new here.

Thanks!
0
Mike JacobsAuthor Commented:
you're a scollop and a gentleman sir

Cheers
0
Mike JacobsAuthor Commented:
see my comment beginning "Well that's a novel one"
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Software

From novice to tech pro — start learning today.