We help IT Professionals succeed at work.

Fields added in WordPress Pages do not appear on the Live site or Preview Changes

MASWORLD
MASWORLD asked
on
Hi Experts
On my Live site I am trying to add some new Fields to my pages Like Image text etc
but when added these Fields  in WordPress Pages it not appear on the Live site or Preview Changes however they appear in Wordpress Page  Editor
Comment
Watch Question

Terry WoodsIT Guru
Most Valuable Expert 2011

Commented:
If you have a caching plugin active in WordPress, you may need to clear the cache from the Dashboard then refresh the frontend page in your browser. Most caching plugins I've seen add a link for clearing the cache to the bar at the top of the page when you're viewing the Dashboard.

Author

Commented:
Thanks Terry
i installed WP Super Cache and clear Cache Contents but nothing happens
Terry WoodsIT Guru
Most Valuable Expert 2011

Commented:
Perhaps you could open your browser's dev tools and check the console for any javascript errors appearing on the Edit Page?
David FavorFractional CTO
Distinguished Expert 2019

Commented:
I'd take Terry's suggestion one step further.

1) Clear your cache.

2) Disable your WordPress caching plugin during development.

3) Disable your PHP Opcache caching during development (far more maddening than WordPress caching problems).

4) Enable WP_DEBUG in your wp-config.php file + check your debug file first, whenever you hit a problem.

For the problem you describe, I'd camp on the debug.log file (as in tail -f debug.log) + then test every step of your process, like watching what emits in your debug file when you hit save or publish.

If you can't camp on your debug file (no ssh access), then you have two other options.

1) Do one operation + download your debug file via SFTP + review changes.

2) Mount your WordPress DocumentRoot (install directory) onto your local machine (use curlftpfs) so you can camp on your remote log from your local machine.

Sounds like possibly a database error being thrown, which isn't reported correctly.

Ah... Also be sure you're running latest WordPress, which today is 4.9.8 so you have all recent bug fixes installed.

Author

Commented:
Thanks all
@David Favor
after enable debugging mode i got this error
Warning: count(): Parameter must be an array or an object that implements Countable in /home/j6tiri37j06d/public_html/mydomain.com/wp-includes/post-template.php on line 284

Author

Commented:
and this

Warning: Declaration of Nav_Walker_Nav_Menu::start_el(&$output, $item, $depth, $args) should be compatible with Walker_Nav_Menu::start_el(&$output, $item, $depth = 0, $args = Array, $id = 0) in /home/j6tiri37j06d/public_html/mydomain.com/wp-content/themes/mydomain/functions.php on line 514
Development Manager
Commented:
Hi there if you are adding fields have you updated the template to display them? When adding fields to post types in wordpress you need to call the get_pos_meta function more information here https://developer.wordpress.org/reference/functions/get_post_meta/