Cannot run Power Shell

My website has recently gotten a new IP-address (shared host), but though the rest of the world can see it, I cannot, even after 48 hours. I have flushed my DNS, but to no avail. The problem comes in all browsers. Flushed my cache as well, but the problem remains.

While trying I also found that I cannot start the power shell either normally or as admin. Nothing happens when I click on them (The command prompt itself comes up outside the power menu). I have added this key: Windows Registry Editor Version 5.00
but again no use. I am on W10
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

bbaoIT ConsultantCommented:
what's the your domain name and what's the link to your website?
is the website working well by visiting the IP address directly?
Michael B. SmithManaging ConsultantCommented:
In regards to running PowerShell, open a cmd.exe session. Then type powershell.exe. That should give you a PowerShell session. Did it?

In regards to your website, check the contents of c:\windows\system32\drivers\etc\hosts. See if your website is listed there. To edit that file, you need to have opened it from an elevated PowerShell session or an elevated cmd.exe session.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
TheoAuthor Commented:
Thank you gentlemen.
@BBAO: The website is at . I can reach it with my mobile allright, but not with my pc, so I think it is a local problem.
@Michael Smith: Yes in a command prompt I get the powershell started, though I do not know how to do that as an administrator.
Starting with Angular 5

Learn the essential features and functions of the popular JavaScript framework for building mobile, desktop and web applications.

Michael B. SmithManaging ConsultantCommented:
You right-click on cmd.exe and "run as administrator". Then, when you enter powershell.exe, it's also an elevated PowerShell session.

Did you check the contents of the hosts file?
TheoAuthor Commented:

I can only get into the Powershell through the Command Prompt and do not know how to do that as an Admin. The right clicking you mention is a menu thing and doesnt work here. The menu appears, but the Shell never opens, either the Normal or or the Admin one.
By the way, when I am in the Command prompt and try to do 'net stop dnscache' I get the message that it is invalid. (And I want to stop the DNS to reach my site.
Michael B. SmithManaging ConsultantCommented:
You can't stop dnscache, you can only flush it ("ipconfig /flush").

Is your SITE running on your Windows 10 computer? Or on a server?

Did you look at the contents of the hosts file?
TheoAuthor Commented:
No my site is running on a shared host.
Meanwhile I have opened my hosts-file (not in the command prompt but in regular windows.)  I can see that the IP-address is wrong but I cannot change it for lack of permission. And though I can open PowerShell in the Command Prompt I do not know how to do that as admin.. The elevated Powershell is available in the menu, but clicking on it has no effect.
TheoAuthor Commented:
When I check the permission for that hosts file, I see that I am in Full Control, but yet..
Michael B. SmithManaging ConsultantCommented:
You need to log in as an administrative user or get an administrative user to help you. I'm sorry, but I can't tell you how to work around your local security configuration.
TheoAuthor Commented:
I understand, I'll make another question directed at security people
TheoAuthor Commented:
I can open PowerShell now, though still not as an administrator. To solve the original problem: my website could not be reached due to IP-change, the recommendation to edit the hosts-file was correct, though my attempts there were plagued by the permissions problem. I was denied access, but when I came back later, the hosts file was changed nevertheless and works now allright. For the remaining permissions problem I have opened a new Question. Michael thanks.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today

From novice to tech pro — start learning today.