Desktop File Sharing

mikesmithccs
mikesmithccs used Ask the Experts™
on
I have a Workgroup of about 9 computers. One of the Windows 10 desktops serves as a share for 2 spreadsheets. Everyone can access the share except one PC gets "Network error: Cannot access \\OHDSales, Error code 0x80070035, The network path was not found." The "server" and the "client" are both Windows 10 Pro. The client could not see any PCs on the network via Windows Explorer until I enabled SMB\CIFS1.0 under control panel >> Programs Features >> Add/Remove Windows Features. Now it can see all the network PCs (AND WILL EVEN GET PROMPTED FOR CREDENTIALS WHEN CLICKING ON AAANNNYYY OF THEM! BUT PROMPTS ONLY THE ABOVE STATED ERROR IF TRYING TO ACCESS THE SHARE ON THE "SERVER.)

I can ping the "server" IP. But can't access the share via Windows Explorer using \\hostname or \\IPAddress.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
mikesmithccsOwner/Operator

Author

Commented:
BTW, No antivirus installed on the "server." Only Windows Defender (which the firewall is currently disabled).
mikesmithccsOwner/Operator

Author

Commented:
Hello?
Ensure you’re charging the right price for your IT

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Martin NguyenHelpDesk Technician
Distinguished Expert 2018

Commented:
Hi mikesmithcc,

Do any of the other PCs in the Workgroup get prompted for credentials when clicking on other computers in the network? Or is this only afflicting your "client" computer?
If the other computers share a file with the affected "client", is it able to access them?
The "client" can now see the "server" on the network, but can't access the 2 spreadsheets?

Sorry if these are a lot of questions that might seem silly, but I just want to clarify your situation.
Martin Nguyen

Commented:
So while I suspect you have done all that, can you check the IP address of the machine that cannot connect and make sure it is on the same network. A manual entry in the IP panel could cause this machine to have a bad mask, bad network address, or just not be on the net.

Can that same machine see any of the other machines and/or the internet itself?
JohnBusiness Consultant (Owner)
Most Valuable Expert 2012
Expert of the Year 2018
Commented:
Pick the machine that is your server - the Windows 10 machine.

Follow all the steps in my article below.

https://www.experts-exchange.com/articles/16639/Folder-sharing-on-modern-machines.html

Make sure of all the settings. Also re-disable SMBv1 - gaping security hole.

Now make user id's and passwords that are the user names and passwords of all the machines trying to talk to Windows 10.

Restart all machines and try connecting again.  Please let us know.
Distinguished Expert 2018

Commented:
"The client could not see any PCs on the network via Windows Explorer..." - and that is normal and expected, even desirable behavior. Don't use the network neighborhood looking for shares, but map drives.
"I can ping the "server" IP" - ping is no indicator at all. It just tells you, that the machine is alive, but nothing about file sharing.

"No antivirus installed on the "server."" - what about the client that has the problem? Any AV active there apart from windows defender?
Top Expert 2016
Commented:
But can't access the share via Windows Explorer using \\hostname or \\IPAddress

you probably mean that you can't access by \\hostname\sharename or \\IPAddress\\sharename

as the other pc's ask for credentials you can't access the share without credentials as well. you have two choices:

either add an account with username and password for each "client" pc. username and password must be the same as at the client pc. then, configure the share such that all the user have access.

or - perhaps better - follow the advice of McKnife and map a drive letter to the share at each client pc. you can do that in the windows explorer when 'This PC' is selected by button in the 'Network' section of the header aera. choose a drive letter and add the  \\IPAddress\\sharename and then provide the credentials to the server.

Sara
mikesmithccsOwner/Operator

Author

Commented:
Owen, all these PCs have to keep a static IP because one of the software programs they run requires it. But the target has a valid mask and matches all others. This machine DID actually have the same problem as the one client I worked from (none of the other PCs could be seen  under Windows Explorer >> Network until after I enable Windows Feature from Control Panel, SMB1.0/CIFS). I think the only time I've seen that SMB problem, was after Windows 10 first release, a lot of copier techs were screaming. However it can now "see all PCs in Windows Explorer, but even before that, all other PCs were and are accessing the share just fine, only the one client is having trouble.

Commented:
Thanks for the update Mike. This is a strange one.

Can this machine connect to a share on any other machine?
Is there any chance of a duplicate IP on the network?  Maybe change the IP (since it is static) to a new IP and see if anything changes.

Grasping at possibilities here now, sadly.
mikesmithccsOwner/Operator

Author

Commented:
Martin, all the PC can potentially access any other PC shares (i.e, they get a cred prompt. They are already all connected to this share and are experiencing now problems. A mixture of W7Pro and W10Pro. I haven't tested whether the "server" can access other shares on other PC but have verified that the server can NOT access a share from the problem client and vice versa. It seems to be a problem between these two PCs. Before neither showed any other network PCs in Windows Explorer under Network, but after enabling SMB1.0 in Windows Features they have all the other PCs on the network showing up. And get cred prompts if try to double click on any, except these two.
mikesmithccsOwner/Operator

Author

Commented:
McKnife, nothing apart from Windows Defender on the client either
mikesmithccsOwner/Operator

Author

Commented:
sarabande, can not access share by \\hostname\sharename or \\IPAddress\\sharename either. Get the same "Windows cannot access" error. Cannot map a drive

Commented:
Have you tried this with the firewalls disabled?  Do you have other firewall software on either machine?
I would turn them off one at a time and see if any change. This is unlikely the problem, but lets eliminate things to be sure.
Business Consultant (Owner)
Most Valuable Expert 2012
Expert of the Year 2018
Commented:
Did you try setting up the users as I suggested?

Open a command prompt and type NET USE \\IPaddress\share and then report the numerical error you get.
mikesmithccsOwner/Operator

Author

Commented:
Will double check for duplicate right now, although I'm not onsite to unplug the suspect. Will compare mac address with whats in firewall. I can't check for accessing other shares as there currently are no others and not onsite at the moment. Oddly enough their is a Toshiba Copier on the network with file shares and both machines can access that share just fine
mikesmithccsOwner/Operator

Author

Commented:
John, I have not but am about to read the article now. And see about setting up users. Sorry, was trying to answer the ones I could quickly
JohnBusiness Consultant (Owner)
Most Valuable Expert 2012
Expert of the Year 2018
Commented:
Thanks. Please keep us posted.
mikesmithccsOwner/Operator

Author

Commented:
JOhn, "You can't access this shared folder because your organization's security policies block unauthenticated guest access. These policies help protect yur PC from unsafe or malicious devices on the network" is what net use reports
JohnBusiness Consultant (Owner)
Most Valuable Expert 2012
Expert of the Year 2018

Commented:
Did you disable SMBv1 and did you check that all connections are Private - not public, and did you ensure Homegroup is OFF.
mikesmithccsOwner/Operator

Author

Commented:
I created a user and password on the "server" for the affected client. Now it work! Thanks! I knew that was an option but I've never been forced to do that before. Thanks again!
JohnBusiness Consultant (Owner)
Most Valuable Expert 2012
Expert of the Year 2018

Commented:
Thank you. That is how it works now so good to go.

Commented:
The need to do that  sounds like a connection profile with the local username and password of the affected machine was already saved on the affected machine.  If that is saved, then every time you try and connect it would use the local name and password, which was failing before you added it to the server.

Start->Control Panels-User Accounts->Manage Your Credentials and look and see if a stored credential was saved on the client machine for the target server. That may have been causing the problem.

Glad you got it to work.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial