No user can authenticate and log in to main sharepoint site

Our sharpoint site is running on sharepoint 2010 SP2 with the latest CU installed.

One morning we started getting calls from users saying that they couldn't access our sharepoint site. We tried logging in from our computers and from the server and cannot connect to it. We get a pop up that asks for credentials. No matter what credentials we put in, it will not allow us to connect. It is noteworthy that we CAN connect to the sharepoint central administration site, as well the sharepoint user "My sites" that use a different port number.

We have created test sites through IIS to see if it is an IIS problem. Our test sites are working. We can connect to them and authentication works.

We have also applied some registry changes that were suggested in the below KB.

https://support.microsoft.com/en-us/help/896861/you-receive-error-401-1-when-you-browse-a-web-site-that-uses-integrate

Applying those registry changes did not fix the problem.

Before this problem started happening, we did not make any changes to that server, or to our network.

We would greatly appreciate any insight you could provide to help us with this problem. Thank you.
LVL 1
FSYRDirector of ITAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Walter CurtisSharePoint AEDCommented:
One of the first things to check based on what you describe, make sure the service account that is running the app pool in IIS for your main site has not been disabled or changed in any way. Also check in SQL that the app pool service account has not be deleted or disabled.

Hope that helps...
0
FSYRDirector of ITAuthor Commented:
Yes, the service account running the app pool is correct, is not disabled, is not locked out and has not been modified. This account is still in SQL and is listed as a dbowner on all the SharePoint databases.

Some further details: The site is listed in the 'Local Intranet' security zone for IE and 'Automatic logon in intranet zone' is also enabled. Users were able to access the site with no login prompt up until yesterday morning. The site also appears to still be functioning properly (this morning I received an email about an approval task that I had due) we simply can't get to the site.
0
Walter CurtisSharePoint AEDCommented:
That's good news about the service account. Also, you state:

It is noteworthy that we CAN connect to the SharePoint central administration site, as well the SharePoint user "My sites" that use a different port number.

That's a good sign and means the server is in the domain still and authorization works for those web apps. As far as the other web app, the one that is not working, check the basics. Is the url correct? Try going to this url:

http://yourPortal/_layouts/15/settings.aspx 

If you can access that page, that is good. Let me know results please.

Good luck...
0
10 Tips to Protect Your Business from Ransomware

Did you know that ransomware is the most widespread, destructive malware in the world today? It accounts for 39% of all security breaches, with ransomware gangsters projected to make $11.5B in profits from online extortion by 2019.

FSYRDirector of ITAuthor Commented:
Trying to go to that URL (or directly to any subsite), we get the user credential pop-up just like when we try to go to the homepage.
0
Walter CurtisSharePoint AEDCommented:
Sure you tried this, but maybe restart the server(s).
0
FSYRDirector of ITAuthor Commented:
We got it fixed. The IIS site had become corrupted in some way (don't know what was messed up in IIS, or how it happened). Found this article: https://blogs.msdn.microsoft.com/sharepoint__cloud/2012/03/03/change-web-application-port-number-in-sharepoint-2010/

It discusses deleting SharePoint from the IIS site (and the site within IIS as well), and then Extending SharePoint back to IIS and recreating the site (the blog is doing it to change the port, but we just assigned it port 80 again). After the site was recreated, it comes right up with no login prompts. Thanks for your help!
0
FSYRDirector of ITAuthor Commented:
1. Open Central Administation Site, go to Manage web application -> Choose the web application and in the ribbon Click on the arrow below Delete web application. Choose Remove SharePoint from IIS web site.

2. In the pop up box, make sure the right IIS site is chosen.

3.Make sure to also check the box 'Delete from IIS' and click OK.

4.Click on the site again and now click on Extend in ribbon.

5. Fill in the details with the required port number and click OK.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Walter CurtisSharePoint AEDCommented:
Glad you got it fixed.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SharePoint

From novice to tech pro — start learning today.