Avatar of cawasaki
cawasaki
 asked on

upgrade exchange 2013 cumulative 15 to cumulative 21

hello

i need expert advice to now what i need to do to install exchange 2013 cumulative update 21 from exchange 2013 cu 15 installed.

i am on windows 2012 r2 with  9 server exchange 2013 cu15 and .net framework 4.5.1 (the relaese on registry indicate 378675).

can some one tell me what are the road to upgrade to Cumulative 21?
1- are update active directory schéma is needed?
2-what are the prerequisites
3- are higher .net framework version is needed (actually 4.5.1 on server)

thanks for help
ExchangeWindows Server 2012

Avatar of undefined
Last Comment
cawasaki

8/22/2022 - Mon
ASKER CERTIFIED SOLUTION
Wadski

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
cawasaki

ASKER
hello Wadski

thanks for this, other question, i need to undestand how .net framework work, are the installation of the 4.7.1 delete old 4.5.1 .net framework? i ask because i have scanmail for exchange and i think its support only .net framework 4.5 version.
Hani M .S. Al-habshi

Just install CU 21
setup 》run
M A

-->1- are update active directory schéma is needed?
No

-->2-what are the prerequisites
Run the setup would be enough.


-->3- are higher .net framework version is needed (actually 4.5.1 on server)
Install .net 4.6.2
https://blogs.technet.microsoft.com/exchange/2017/06/13/net-framework-4-7-and-exchange-server/
Experts Exchange has (a) saved my job multiple times, (b) saved me hours, days, and even weeks of work, and often (c) makes me look like a superhero! This place is MAGIC!
Walt Forbes
cawasaki

ASKER
hello,

what i see here: https://blogs.technet.microsoft.com/exchange/2018/06/19/released-june-2018-quarterly-exchange-updates/

the cu21 of exchange 2013 need .net framework 4.7.1

other question, if i install .net framework 4.7.1, are .net framework 4.5.1 is removed or not? because our mail antivirus work only with 4.5.1 framework version.

thanks
Wadski

Hi

It all depends on your version of Scanmail.  If you have version 12.0 then it needs .net framework 4.5.0. If you have 12.5 then it will work with 4.7.1.

Installing 4.7.1 will update 4.5.0 so potentially leave Scanmail unoperational.

This link says Scanmail 12.0 is compatible with CU21 but, as you say, it requires 4.5.0

https://success.trendmicro.com/solution/1116926-scanmail-for-microsoft-exchange-smex-12-0-and-12-5-support-statement

Do you have support contract for Scanmail? It may be worth speaking with hem if so as it’s ambiguous.
cawasaki

ASKER
HELLO Wadski?

this is exactly my problem, i have scanmail 12.1 its compatible with cu21 but need .net framework 4.5, i have ask Microsoft support and i am waiting the answer to now if when install .net framework 4.7.1 it keep 4.5.1 version or not.

and yes i will ask scanmail support.

thanks
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
Wadski

When you install 4.7.1 to will replace 4.5.0.

This version of the .NET Framework runs side-by-side with the .NET Framework 3.5 SP1 and its earlier versions. However, it performs an in-place update for the .NET Framework 4, 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, and 4.7.
Source: https://support.microsoft.com/en-gb/help/4033342/the-net-framework-4-7-1-offline-installer-for-windows
Wadski

Found a Microsoft document stating that all versions of .net framework 4.5 and beyond are backwards compatible

https://docs.microsoft.com/en-us/dotnet/framework/migration-guide/version-compatibility
cawasaki

ASKER
hello Wadski,

are this mean application need 4.5.x framework will continue work after update to 7.7.1?

thanks
Your help has saved me hundreds of hours of internet surfing.
fblack61
Wadski

Yes.  Which is why it says on the TrendMicro site that 12.0 is compatible with CU21
cawasaki

ASKER
hello,

thank for help:

Trend say we need to upgrate to 12.5 first to be supported :).