A listener channel for protocol 'http' in worker process '####' serving application pool '...' reported a listener channel failure. The data field contains the error number - APP POOL CRASHING!

I am running a .NET 2.0, 32-bit application in IIS.  Recently the app pool keeps crashing as soon as I start it.  It was fine for over a year.  I keep getting a series of listener channel errors:

A listener channel for protocol 'http' in worker process '4732' serving application pool ... reported a listener channel failure.  The data field contains the error number.
I get this error 5 times then the APP Pool crashes with a browser 503 error.  Worker process numbers are always the same 5.  

Worker process '1084', then '4732', '5644', '6064' and '3724' -- all listener channel errors and application pool crashing.  I don't understand what changed.  There were some updates on the server 2 weeks ago, but nothing else was modified.  Can someone shed some light on this issue for me?
Kathryn ThomasAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Chinmay PatelChief Technical NinjaCommented:
Hi Kathryn,

Please check the event log of the server - do not put any filters - just check the entries around the time your app pool crahsed. Also let me know which OS you are running? Version of IIS? What updates were applied 2 weeks ago - if possible do get me the list of the updates which were applied. I think rest will have to wait till you can provide some information from the eventlog. Please do eradicate sensitive information before you post the eventlog here.

Regards,
Chinmay.
0
Kathryn ThomasAuthor Commented:
I am running Win Server 2008 R2.  I have enclosed the warnings and error messages that I keep getting each time I start the App Pool.  I have enclosed a snapshot of the latest updates and programs installed.  I have removed all updates that were applied in Sept.  This problem only happened recently so anything before Sept doesn't apply.
latest_installs.jpg
latestUpdates.jpg
ErrorLogs_EventViewer_AppCrashing.evtx
0
Kathryn ThomasAuthor Commented:
Error: 503 Service Unavailable. Causing app pool to stop working.

This error is in the windows application log

Error:“HipIISEngineStub.dll failed to load. The data is the error.”
Solution
This is a know issue with a McAfee update on a web server.

Edit the IIS 7.0 applicationHost.config file and remove the following configuration lines:
Edit %windir%\system32\inetsrv\config\applicationHost.config as Administrator.
In the <globalModules> section, remove the following line:<add name=”MfeEngine” image=”%windir%\System32\inetsrv\HipIISEngineStub.dll” />
In the <modules> section, remove the following line:<add name=”MfeEngine” />
Save the file, then restart IIS.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
.NET Programming

From novice to tech pro — start learning today.