Need help with New-ComplianceSearch

Hi all,

I am currently trying to get the New-ComplianceSearch stuff in Exchange 2016 working, but I am having some problems.

First of all, i can confirm that I am a domain admin and am a member of the Discovery Management Exchange AD group.

When I run the command:

New-ComplianceSearch -Name "SearchTest" -ExchangeLocation All -ContentMatchQuery "Test"

Open in new window


I  get the following error:

compliancesearch1.PNG
Interestingly, if I just run the command 'New-ComplianceSearch' it looks like it begins the process, but it fails whenever I try to specify a name...

compliancesearch1.PNG
What am I doing wrong?

Thanks
compliancesearch2.PNG
fieldjAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

timgreen7077Exchange EngineerCommented:
Instead of parameter -ExchangeLocation being set to All, try to use your email address and see what the result would be from a single searched item instead of attempting to search all mailboxes and so forth, so something like this:

New-ComplianceSearch -Name "SearchTest" -ExchangeLocation "user@domain.com" -ContentMatchQuery "Test"
0
timgreen7077Exchange EngineerCommented:
Also have you tried performing the same search in the Exchange Admin Center under compliance management > inPlace eDiscovery & Hold since you are doing the same thing but in the GUI.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
fieldjAuthor Commented:
I just tried the same thing in EAC (I didnt actually know this existed!) and although it let me create the job, it would just sit queuing.

This led me to the following document which says this might happen during coexistence (I still have an Exchange 2010 server in the environment) if the SystemMailbox{e0dc1c29-89c3-4034-b678-e6c29d823ed9} still exists on one of the 2010 DB's (which it does).

http://techgenix.com/ediscovery-during-coexistence/

I am just in the process of migrating that mailbox to 2016 so I am hoping that this will help me get closer to get this working.
0
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

timgreen7077Exchange EngineerCommented:
yep that is true, the system mailbox needs to migrated to 2016 first.
0
fieldjAuthor Commented:
I have been able to use EAC tool successfully after migrating the SystemMailbox{e0dc1c29-89c3-4034-b678-e6c29d823ed9} mailbox.

This has helped me to achieve what I need.  Thanks
0
timgreen7077Exchange EngineerCommented:
good deal
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.