exchange migration and outlook not quite working

Hi, I am migrating from exchange 2010 (sbs 2011) to exchange 2016.
I have a test account that I have migrated from 2010 to 2016. When i open outlook after the mailbox move, it connects and mentions that it needs restarting to reconfig itself. Which i do. All works fine.

If I then close and open outlook, i get the below screen shot.
I am testing this with outlook 2010.

outlook error
LVL 1
total123Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

timgreen7077Exchange EngineerCommented:
When you finish moving mailboxes from Exchange 2010 to 2013 or 2016, don't forget to restart the Autodiscover application pool on your new 2013 CAS servers or 2016 mailbox servers:

Restart-WebAppPool MSExchangeAutodiscoverAppPool
0
total123Author Commented:
hi, thats not worked. Should i have done some autodiscover redirect ?
0
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

total123Author Commented:
That's the site Ive been following. What I noticed an hour ago is that I had skipped part 3 by stupidly clicking to part 4 without realising. I've gone through part 3 to add the URLs and Autodiscover parts. Still to no change thou
0
timgreen7077Exchange EngineerCommented:
give me an example of what URLs are now? Doesn't have to be the actual one but tell me what they are?
0
total123Author Commented:
before I do that, it seems i've messed up the phones from picking up emails. I had followed this bit of the instruction and now phones cannot see the old server, externally and internally. And the exchange admin center is giving me error 500.
Look this up, people suggest rebuilding the owa virtual directory. As I did the below, would this actually reset it to it's old setup. Which i can't remember. except that it had something.internaldomain.local, where as part 3 of this site says to put in mail.mydomain.com

would rebuilding owa virtual directory work ?

from part 3 of site
Figure 15: Locating Outlook Anywhere settings

In the Exchange Server properties window choose the Outlook Anywhere tab. Update the External Host Name, Internal Host Name and Authentication Method as shown below:
0
IvanSystem EngineerCommented:
Hi,

if you try to create new Outlook profile for that mailbox, does it works?
What Outlook 2010 version do you have? To connect to Exchange 2016 you should have Outlook 2010 SP2 and few more updates.

Regards,
Ivan.
0
total123Author Commented:
ivan, I've got later than sp2 on it and new profiles don't work
0
IvanSystem EngineerCommented:
Hi,

when you are doing 2010 to 2016 migration, usually you redirect autodiscover to Exchange 2016, since 2016 does know how to redirect Outlook back to Exchange 2010, but not other way around. That is why autodiscover cannot connect you to Exchange 2016 mailbox.

Regards,
Ivan.
0
Saif ShaikhServer engineer Commented:
Normally the exchange 2016 server does a reverse proxy to exchange 2010 or 2007 servers, when a mailbox is moved to 2016. So internally in the DNS the mail.domain.com A record still points to exchange 2010 internal IP, however exchange 2013 does a reverse proxy.

So did you exported the third party certificate and imported the same in exchange 2010 and did you also set all virtual directories to mail.domain.com.

Make sure that you do not set the autodiscover URI on 2016 to mail.domain.com it should be set to NULL on 2016 server because we need to make sure that any request for Outlook client goes to exchange 2010 server.

Also for testing when you moved the test mailbox since internal DNS pointing is still on 2010 server, try to add exchange 2016 IP in the host file of the test outlook and check whether we get outlook connected. If test passes then you don't need to do anything.

But if the test fails then you need to take a downtime and change the internal DNS pointing to exchange 2016 server internal IP. Then verify the moved mailbox outlook connectivity and if it is success then revert the changes and go to next step i.e. create migration batch for all mailboxes and sync to 95%.
0
total123Author Commented:
here's a few urls from exchange 2016 shell

Server IPS
2011sbs - 192.168.100.202
exchange - 192.168.100.205

DNS is setup as follows
mail.domain.co.uk - 192.168.100.202
remote.domain.co.uk - 192.168.100.202


owa URL

[PS] C:\Windows\system32>Get-ExchangeServer | Get-OutlookAnywhere | fl Identity, *ternalhost*, *ticationmeth*


Identity                           : 2011SBS\Rpc (Default Web Site)
ExternalHostname                   : remote.domain.co.uk
InternalHostname                   :
ExternalClientAuthenticationMethod : Basic
InternalClientAuthenticationMethod : Ntlm
IISAuthenticationMethods           : {Basic, Ntlm, Negotiate}

Identity                           : EXCHANGE\Rpc (Default Web Site)
ExternalHostname                   : mail.domain.co.uk
InternalHostname                   : mail.domain.co.uk
ExternalClientAuthenticationMethod : Basic
InternalClientAuthenticationMethod : Ntlm
IISAuthenticationMethods           : {Basic, Ntlm, Negotiate}

Autodiscover URL

[PS] C:\Windows\system32>Get-ExchangeServer | Get-ClientAccessServer | fl Identity, *ternaluri*
WARNING:  The Get-ClientAccessServer cmdlet will be removed in a future version of Exchange. Use the
Get-ClientAccessService cmdlet instead. If you have any scripts that use the Get-ClientAccessServer cmdlet, update them
 to use the Get-ClientAccessService cmdlet.  For more information, see http://go.microsoft.com/fwlink/p/?LinkId=254711.


Identity                       : 2011SBS
AutoDiscoverServiceInternalUri : https://remote.domain.co.uk/Autodiscover/Autodiscover.xml

WARNING:  The Get-ClientAccessServer cmdlet will be removed in a future version of Exchange. Use the
Get-ClientAccessService cmdlet instead. If you have any scripts that use the Get-ClientAccessServer cmdlet, update them
 to use the Get-ClientAccessService cmdlet.  For more information, see http://go.microsoft.com/fwlink/p/?LinkId=254711.
Identity                       : EXCHANGE
AutoDiscoverServiceInternalUri : https://autodiscover.domain.co.uk/Autodiscover/Autodiscover.xml
0
Saif ShaikhServer engineer Commented:
I hope that your third party SSL certificate has autodiscover.domain.com entry in it and host A record for the same is pointed to exchange 2016 public IP.

Set the exchange 2016 auto-discover URI to null as I said earlier since exchange 2016 will reverse proxy to 2010.

Perform firewall changes in order to route mail flow and port 443 traffic to Exchange 2016 server.

After setting the URI to null test by moving a test mailbox to 2016 and test outlook functionality.  All DNS records will still point to 2010 server internal IP. This change needs to be done only after all mailboxes are moved in a batch.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
total123Author Commented:
hi, I ended up getting an experts exchange paid help that sorted it, I also had DNS issues in the back ground. long story, took 2 hrs.

can't remember what fixed url

but outlook issue was due to the test pc i was running, some how kept getting some random external IP we don't own, being used for autodiscover. we ended up manually putting the correct IP into hosts file and that seem to resolve it.
0
Saif ShaikhServer engineer Commented:
That was what I suggested you to add exchange 2016 internal IP in the host file of the test Outlook..
0
Saif ShaikhServer engineer Commented:
Glad to here your issue is resolved now..
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.